When I scroll in Firefox 3.0, the page jumps two or three sections even if I only cli

Discussion in 'Mac Apps and Mac App Store' started by Luckyword, Jul 4, 2008.

  1. Luckyword macrumors newbie

    Joined:
    Jul 4, 2008
    #1
    That is, if I'm reading an article, and I put the cursor at the bottom of the scroll bar, and click once, Firefox will scroll two or three sections sometimes. This is very annoying, and didn't happen in Firefox 2.0. To clarify, I'm reading, and I click once, and want the page to jump down one section, and instead it jumps two or three. I've experimented with autoscrolling on/off, and this doesn't help the problem. Should I switch back to Firefox 2.0? One solution is to position the cursor barely below where I want to go, so Firefox can't jump ahead, but I find this annoying and would just as soon switch back to 2.0. Please help. Thanks. David
     
  2. clevin macrumors G3

    clevin

    Joined:
    Aug 6, 2006
    #2
    This is probably not a problem with firefox3, Im using it right now, and I didn't see the problem..

    maybe you can post two screen shot comparing before and after clicking? and see if we can confirm it.

    If you want to try something for now, please do try a new profile
     
  3. Luckyword thread starter macrumors newbie

    Joined:
    Jul 4, 2008
    #3
    It's gotta be firefox...

    ...'cause this doesn't happen in Firefox 2.0. But it does happen in 3.0.
     
  4. nemodomi macrumors member

    nemodomi

    Joined:
    Jul 6, 2008
    #4
    a work-around

    I've resorted to using the "page down" key, which still works appropriately.
     
  5. scotty96LSC macrumors 65816

    scotty96LSC

    Joined:
    Oct 24, 2007
    Location:
    Charlotte, NC
  6. Luckyword thread starter macrumors newbie

    Joined:
    Jul 4, 2008
    #6
    Firefox problem with scrolling...

    ....okay, good, glad it's not just me. Does anyone out there have a solution to this prob. Should I just use Firefox 2.0, which didn't have this glitch?
     
  7. G-Com macrumors regular

    Joined:
    May 21, 2008
    Location:
    North of The 'Nati
    #7
    Did you try adjusting the scrolling speed in System Preferences?
     
  8. kolax macrumors G3

    kolax

    Joined:
    Mar 20, 2007
    #8
    Not use a scroll capable mouse?

    For big long websites, I use the spacebar instead of having to move the cursor.
     
  9. clevin macrumors G3

    clevin

    Joined:
    Aug 6, 2006
    #9
    I still can't confirm the problem, so really can't contribute too much.

    if you have a scrollable mice, other than method mentioned above, click scroll button once will bring up reference point, just move mice to scroll to the directions relative to the reference point.
     

    Attached Files:

  10. Luckyword thread starter macrumors newbie

    Joined:
    Jul 4, 2008
    #10
    Firefox

    I don't use a scrollable mouse, 'cause I'm on a Powerbook G3 400 Pismo, the best PB ever made! :)
     
  11. carl2615 macrumors newbie

    Joined:
    Aug 22, 2008
    #11
    Multiple page jumps, Firefox 3.0

    Same problem, on multiple page jumps in Firefox 3.0.1 when advancing web page. Problem occurs when using both trackpad or "fn" and "pg dn" keys.
    - non-scrolling trackpad
    - iBook 500 running OS 10.4.11
    - problem just appeared in August O8
    Also, single page-down now is not a "jump", but "ratchets-down" in several small increments in Firefox 3.0.1.

    Has anyone determined the cause and developed a solution?
     
  12. Luckyword thread starter macrumors newbie

    Joined:
    Jul 4, 2008
    #12
    Still doesn't work

    I'm glad it's not just me. I switched back to 2.0 because of this annoying problem.
     
  13. dadoc04 macrumors member

    Joined:
    Jul 19, 2008
    Location:
    Jax & DMV
    #13
    i was having the issue as well. check your preferences/advanced section

    [​IMG]
     
  14. DjBlairQ macrumors newbie

    Joined:
    Dec 8, 2008
    #14
    Problem Solved

    I had this same problem in Firefox 3 and I found the reason.

    Go to Tools > Options > Advanced Tab > General Tab > Accessibility > and UN-CHECK 'Always use cursor keys to navigate within pages'.

    This feature when checked puts the text cursor within the page to jump around between text and also highlight the links, making it click-able with the space bar key.

    It worked for me.:D

    DjBlairQ
    djblairq@djblairq.com
    www.djblairq.com
     
  15. jennix macrumors newbie

    Joined:
    Aug 23, 2009
    #15
    This is still the most annoying feature of ALL

    All versions of Mozilla 3.x do this on Mac OSX, including Thunderbird, Flock, and all the other flavors. It sure would be nice if i didn't have to put up with it.
     

Share This Page