When pressing home button from within app... Delay

Discussion in 'iOS 7' started by vaultwit, Oct 1, 2013.

  1. vaultwit macrumors regular

    Joined:
    Sep 20, 2012
    #1
    I've noticed that when I'm in an app and press the home button to go home, there is an annoying delay before the screen actually does anything. Is anyone else experiencing this, or is it just me? It's especially annoying when I accidentally press the wrong app and try to quickly get back to home. I feel like I've gone back in time to the slow iPhone 3G days (I'm exaggerating but you know what I mean).

    I'm using iPhone 5.
     
  2. MinEderPlayz macrumors 6502a

    MinEderPlayz

    Joined:
    Aug 3, 2013
    Location:
    Hamburg, Germany
  3. klogg macrumors member

    Joined:
    Oct 17, 2012
    #3
    It's not just you, it's how Ios works now! I feel the same as you do, and I do hope it will be faster in future updates!
     
  4. vaultwit thread starter macrumors regular

    Joined:
    Sep 20, 2012
    #4
    OOPS I am using iPhone 5. Sorry about that
     
  5. zorinlynx macrumors 601

    zorinlynx

    Joined:
    May 31, 2007
    Location:
    Florida, USA
    #5
    There's a tiny delay there because the phone needs to know you're not double-tapping the home button to access multitasking. I don't see it being long enough to be a problem, though.

    That delay was also present on iOS 6.
     
  6. vaultwit thread starter macrumors regular

    Joined:
    Sep 20, 2012
    #6
    Hmm I think the delay I'm talking about is different. It's definitely longer than what I experienced in iOS 6, sometimes lasting almost 2 seconds. It shouldn't take 2 seconds to figure out if the user is double-clicking the home button.
     
  7. zorinlynx macrumors 601

    zorinlynx

    Joined:
    May 31, 2007
    Location:
    Florida, USA
    #7
    Ahh. Yeah, two seconds definitely sounds like a problem. I'm running iOS 7 on both my iPhone 5 and iPad 4 and they both quickly go to the home screen when I push the button.

    Look in Settings -> General -> Accessibility and make sure that "Home click speed" is on "Default"?

    EDIT: Yep, this could definitely be the cause. I set mine to "slowest" and it causes a long pause when you hit home.
     
  8. Altis macrumors 68020

    Joined:
    Sep 10, 2013
    #8
    It's also slower when the Triple-click home feature is set up.

    Although I'm not sure why it leaves more time... if it hasn't detected a second click within the normal time frame, it won't be getting a third. I don't understand it, but alas, that's how Apple has programmed it. :rolleyes:
     
  9. vaultwit thread starter macrumors regular

    Joined:
    Sep 20, 2012
    #9
    I didn't even know that feature existed. In any case, whether it is in "default" or "slowest" it is the same speed for me. On "Slowest" I can see that it might be a TAD slower, but it is almost just as slow on "default". What a shame, I thought this was gonna fix it for me.
     

Share This Page