Where are my boot options? Ugh...

Discussion in 'Mac Pro' started by MrWizard64, Feb 1, 2014.

  1. MrWizard64 macrumors member

    Joined:
    Sep 8, 2013
    #1
    Hey Guys,

    So i got my 1,1 off of craigslist... I dont know what was changed before I got it but I typically boot to a black screen with a bunch of text and then after a little while, OSX starts up.

    I never really minded until I wanted to start up to this mavericks install drive... I can't do it. I can't even boot to disk utility.

    It seems like that entire portion of my mac is missing...

    When I leave a completely blank, properly formatted hard drive in the macpro and try to boot to the USB disk, I get nothing but a black screen and after several seconds, my computer completely shuts off....

    What the heck is goin on and what can I do to fix it?!

    Thanks for all of your help in advance.

    ---Trav
     
  2. MacUser2525 macrumors 68000

    MacUser2525

    Joined:
    Mar 17, 2007
    Location:
    Canada
    #2
    That is a verbose boot it is the only way I will boot my machines if something is going wrong I want to know about it. You can edit the following file and remove the -v to have it boot graphically.

    Code:
    cat /Library/Preferences/SystemConfiguration/com.apple.Boot.plist
    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
    <plist version="1.0">
    <dict>
    	<key>Kernel</key>
    	<string>mach_kernel</string>
    	<key>Kernel Flags</key>
    	<string>-v</string>
    </dict>
    </plist>
    

    Mavericks only supports 3,1 or newer machines unless you use a hacked boot loader on it, a search on the forum will show you the details but I think I have only seen it applied to 2,1 models.
     
  3. MrWizard64 thread starter macrumors member

    Joined:
    Sep 8, 2013
    #3
    Cool... So does this mean that ill be able to get into disk utility and such?
     
  4. chrfr macrumors 603

    Joined:
    Jul 11, 2009
    #4
    Rather than manually editing that plist, the preferable way to disable verbose boot is to type the following into Terminal:
    Code:
    sudo nvram boot-args=""
    To reenable verbose boot:
    Code:
    sudo nvram boot-args="-v"


    ----------

    What version of OS X is on the computer now? If it's something earlier than 10.7, there's no recovery partition, and that's why you can't get to Disk Utility at startup.
    10.7.5 (Lion) is the last supported version of OS X for that computer. I wouldn't recommend trying to make something newer work on it at this point.
     
  5. MrWizard64 thread starter macrumors member

    Joined:
    Sep 8, 2013
    #5
    Can you think of any reason why this would have been enabled?

    I cant imagine that it was anything good.

    Ill give this a shot and see what happens... Post back in 10 minutes.
     
  6. chrfr macrumors 603

    Joined:
    Jul 11, 2009
    #6
    Some people just like to see what the computer is doing at startup. There's no reason to be concerned.
     
  7. MrWizard64 thread starter macrumors member

    Joined:
    Sep 8, 2013
    #7
    Well I ran that command and my startup certainly seemed to be quicker... though I didn't have my monitor in that actually displays the text.

    The problem is, I still don't have the ability to boot to disk utility, reset PRam, or any of that kind of thing.

    I really need to boot to a different partition and for whatever reason, I just can't.

    I hold command, or option, or command + r, and I get nothing... no response.

    I don't know how I'm going to move forward with the stuff I need to get done :-(
     
  8. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #8
    Are you using a USB keyboard?
    Some RF wireless (non-Apple) keyboards may not support the various boot commands.
    What does happen when you try the PRAM reset?
    Just to make sure you have the correct key combo, that's restarting, while holding Option(alt), Command, P and R. You should hear the boot chime sound. Continue holding the same 4 keys until you hear the chime two more times, then release the keys to let your Mac boot normally.
    If nothing happens, be sure that you are trying a USB (wired) keyboard.

    What version of OS X does your Mac Pro boot?
    If you are not sure, boot up, then go to the Apple menu/About This Mac
    Anything less than 10.7 (10.6.8, for example) will not have the bootable recovery partition - which is what you are trying with a Command-R.

    As others have posted, your MacPro 1,1 will not install nor boot to Mavericks.
    You CAN boot and install from a USB flash drive with Lion (OS X 10.7.x)
     
  9. MrWizard64 thread starter macrumors member

    Joined:
    Sep 8, 2013
    #9
    I just tried replacing my logic board battery, no dice. I also tried using a wired USB keyboard... also no good.

    Right now, I'm booting to 10.7.5... I am aware that Mavericks isn't supposed to work on this MacPro... I mention it only because that's what I was trying to work around when I realized I can't even boot to disk utility.

    I SHOULD have a recovery partition to boot to... but what if I don't somehow? I suppose that could be a problem. How would I check, or create a new one?

    Even still... the PRAM reset isnt working... that shouldn't have anything to do with the partitions.

    What the heck could be going on here?

    ----------

    Wait.... the PRAM reset worked!

    Ok that's cool. Now why the heck can't I boot to disk utility?
     
  10. MrWizard64 thread starter macrumors member

    Joined:
    Sep 8, 2013
    #10
    Looks like I can boot to disk utility as well!

    I suppose that pretty much means that this install drive that I created is a piece of crap.

    That is most unfortunate :-(

    ---Trav
     

Share This Page