Where can i buy Keynote 5.0.5? (Snow leopard mac)

Discussion in 'Mac Apps and Mac App Store' started by macinfopls, Jun 19, 2012.

  1. macinfopls macrumors newbie

    Joined:
    Jun 18, 2012
    #1
    I'm looking for Keynote 5.0.5 but the mac store is only selling 5.1 for Lion. I'm on an intel running Snow Leopard (to preserve an old version of software i like).Please does anyone know where i can buy 5.0.5?!
    (I plan to upgrade my mac next year but i really need keynote to do a piece of work now aghhhrr!)
    Thanks!
     
  2. tonmischa macrumors newbie

    Joined:
    Apr 22, 2007
    #2
    You can only buy the latest version of Keynote, which is 5.1.1 .
    But the Mac App Store lists Mac 10.6.6 (Snow Leopard) as system requirement, not Lion.
     
  3. macinfopls thread starter macrumors newbie

    Joined:
    Jun 18, 2012
    #3
    snow leopard left out of itunes store

    You need Lion to access the itunes app store, so they block anyone staying with snow leopard. It's designed to force me to either buy another computer, or buy all my software again...
    My old macbook works fine still and it's ten years old now, i just can't get the latest version of safari on it so it won't link up to the web anymore. They turned that one into a typewriter, i suppose this one will go the same way eventually. Annoying when the hardware all works fine still.

    Just wondered if there were any sources of software for the 10.5.8 still around.
     
  4. RickyB, Jun 20, 2012
    Last edited: Jun 20, 2012

    RickyB macrumors regular

    Joined:
    Oct 28, 2007
    #4
    Snow Leopard (10.6) or Leopard (10.5)? Snow Leopard has the Mac App Store (as long as you upgrade to 10.6.8).

    Leopard doesn't, however.

    I think a boxed set of iLife '09 (that says '09 on it, not the ones which just say iLife) might do the trick.

    Have you looked on eBay? There's this one in the UK, maybe better deals where you live

    http://www.ebay.co.uk/itm/Apple-iWork-09-Retail-iLife-09-Retail-Brand-New-Sealed-/261045665497
     
  5. macinfopls thread starter macrumors newbie

    Joined:
    Jun 18, 2012
    #5
    Keynote for snow leopard

    Arr, thats a good idea, thank you! :)
     
  6. sohony macrumors newbie

    Joined:
    Sep 19, 2012
    #6
    you can buy keynote for leopard here

    http://www.ebay.com/itm/Apple-iWork...505&pid=100015&prg=1006&rk=1&sd=271061139730&

    you just have to buy it by friday afternoon, september 21st.

    i bid on it myself but now don't need it, as someone at work had a brand new unopened copy of iwork 09.

    meanwhile i put in a maxium bid of $18.99 which i cant change (grrrr) and may get stuck with it. in which case, please buy it from me!
     
  7. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #7
    Again, Mac OS X 10.5 Leopard and Mac OS X 10.6 Snow Leopard, Mac OS X 10.6 Snow Leopard does not run on PPC Macs, which your Mac would be, if your Mac is ten years old. Or you have an Intel Mac running Mac OS X 10.6 Snow Leopard and not Mac OS X 10.5 Leopard (as a PPC Mac would do), which then would only be six years old at the very oldest.

    And yes, I realise, your post is old.
     

Share This Page