Where did my 10gb go? iBook/10.3.8 HD Problem

gdh

macrumors newbie
Original poster
Jul 16, 2002
12
0
Somehow 10+ gb of space on my new G4 ibook's has magically been filled without me knowing. The last time I checked I had, at most, used 17gb of the 27gb of space on the hard drive. I haven't done anything unusual since - just created some word and excel files, downloaded three itunes songs, browsed the internet, and installed the usual Apple updates.

I installed the newest Apple update last night - could that be what is giving me the hard drive problems this morning? I didn't have any problems in the past until I received the messages "your startup disk is almost full" and "your disk is full" this morning. I checked my hard drive info and only have 400 mb of unused room now. Re-starting the computer didn't help.

Any information as to where my space went and how I can get it back is greatly appreciated.

Thanks
 

Blue Velvet

Moderator emeritus
Jul 4, 2004
21,922
168
Do a find for files larger than say... 50mb.
See if that turns up anything that shouldn't be there...
 

isgoed

macrumors 6502
Jun 5, 2003
328
0
If you get the low on hard disk space warning it may be because you were using a lot of virtual memory (restarting usually returns this memory). Did you had a lot of apps open at the time (also things like classic or BSD)?

Your browser's cache may be filled too (for example if you were watching movies on your browser).

But indeed, best bet is to do a search for recently created large files. If you need to clean up your hard disk I suggest you go to list view in finder and arrange your icons by size (also turn on calculate folder sizes in the folder options).
 

abhishekit

macrumors 65816
Nov 6, 2003
1,297
0
akron , ohio
I would first look at the virtual memory folder. The system stores swap files there which sometimes become very big. Open the terminal (it is in Application/utilities)
then write
cd /var and press enter
then write
sudo du -s -h * and press enter.
It would ask for your password.
this would display the size of a number of folders. See the size of a folder called 'vm'. If its 9 GB it would say '9G'
If that is the case, write
cd vm
rm -f * and press enter.
This would remove the swap files.

hope it helps.
 

rickvanr

macrumors 68040
Apr 10, 2002
3,256
11
Brockville
there's an app called "Where is my disk space?" but I can't find it on versiontracker or macupdate, maybe I'm doing something wrong and you'll have better luck.

If not, I could email it to you.
 

faustfire

macrumors 6502a
Jul 17, 2002
560
0
California
missing 10 gigs

I had the same problem,

Did you run norton AV lately, when norton runs it creates a huge empty file
so it knows how much space is left of your drive. If it is interupted mid scan then this file is not deleted and you are left with a huge chunk of missing space. Running Norton again, to completion, will fix the problem.
 

Kit Fist0

macrumors newbie
Mar 10, 2004
16
0
I have had the same problem on my iBook. My disc space has shrinked from 7Gb free to none.
 

gdh

macrumors newbie
Original poster
Jul 16, 2002
12
0
Thanks

Thanks for the help everyone.

I tried your suggestions but none worked.

After working with Apple support for two hours they suggested that I reinstall my system files. I tried that but half way through it quit saying that there was an error. I was forced to erase everything and do a fresh install. Luckily I had everything important backed up to .Mac.

Neither of the two people I spoke with at Apple (one customer service assistant and one product specialist) had a problem like this before. I clearly should have had space left on the hard drive but the space was being reported as full (0kb available is what it said) and I was unable to open more than one program at at time or save any files. They fished around for a while to see if there were any peculiar files, had me reset the pram and ... but nothing worked.

The error happened after I installed the newest update, so hopefully that was not the cause of the problem.

Thanks again.
 

bbrewster

macrumors newbie
Feb 10, 2005
1
0
10.3.8 Bug (Hard Drive Space Loss)

Just so everyone knows... I have isolated the Macally iShock Driver as the comflict with 10.3.8. It must be deleted and you must reset your log file to resolve the problem and restore the HD Space. bbrewster
 

Kit Fist0

macrumors newbie
Mar 10, 2004
16
0
bbrewster said:
Just so everyone knows... I have isolated the Macally iShock Driver as the comflict with 10.3.8. It must be deleted and you must reset your log file to resolve the problem and restore the HD Space. bbrewster
That is what I ended up doing.
 

bondipete

macrumors member
Jan 16, 2003
47
0
Melbourne, Australia
bbrewster said:
Just so everyone knows... I have isolated the Macally iShock Driver as the comflict with 10.3.8. It must be deleted and you must reset your log file to resolve the problem and restore the HD Space. bbrewster
Where would I find this driver? Tried a search for Macally and iShock and Driver - no joy.