Where did Yosemite go ?!!

Discussion in 'OS X Yosemite (10.10)' started by IA64, Nov 14, 2014.

  1. IA64 macrumors 6502

    Joined:
    Nov 8, 2013
    #1
    So I turned my iMac ( late 2013 SSD 512GB - Bootcamp ) and started Windows, later I rebooted and started OS X 10.10. It used to take around 7 seconds to login window but this time was different.

    Progress bar stuck in the middle and system froze.

    I rebooted into Recovery mode and the disk utility couldn't repair the disk !

    Now I have no idea what to do. the OS is no longer there. I can still see my files from Windows but the volume is corrupted.

    I have 80% free space and barely anything installed ( Adobe and Office suite )

    This has never happened since 10.6 even with HDD !!! :mad:

    There is no HW issue nor the SSD is corrupted, I run weekly checks regularly and system status is like new.

    How come you suddenly lose your OS that easily ? I haven't experienced such thing neither with OS X nor with Windows ever.

    More importantly, what to do now ? I'm typing from Windows 8.1
     
  2. IA64 thread starter macrumors 6502

    Joined:
    Nov 8, 2013
    #2
    More than a 300 views and no one? come on guys I urgently need the machine tonight and time machine is failing maybe because last backup was on Mavericks?
     
  3. deathdruid macrumors member

    Joined:
    Oct 24, 2006
    Location:
    Baltimore, MD
    #3
    Did you try Recovery?

    Edit: Sorry, you said you did. Why not just reformat and reinstall the OS, then restore from Time Machine?
     
  4. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #4
    If it were me, I would have scheduled a Genius Bar appointment at 10:07 AM (after your initial post).

    Sounds like you need to recover/restore ?
     
  5. grahamperrin macrumors 601

    grahamperrin

    Joined:
    Jun 8, 2007
    #5
    Use Recovery OS Disk Utility to verify, not attempt to repair, the affected file system. Then copy the details from the window and use Recovery OS Safari to paste to this topic.
     
  6. IA64 thread starter macrumors 6502

    Joined:
    Nov 8, 2013
    #6
    Hello. There is no Genius Bar in my country only Apple resellers.

    Disk utility cant fix thr drive, asking me to format and restore.

    I tried repairing rhe invalid b-tree count but failed

    I logged in to single user mode and run fsck_hfs -r to rebuild the attributes but that did not work.

    Burned DiskWarrior_Intel_startup to usb and tried booting but stuck at gray Apple logo screen.


    Sorry can't paste as I am typing from phone.
     
  7. grahamperrin macrumors 601

    grahamperrin

    Joined:
    Jun 8, 2007
    #7
    invalid b-tree count

    That type of inconsistency can be very troublesome.

    Without regard to the type of inconsistency: DiskWarrior may be unable to handle some HFS Plus file systems. I'm off out now, if I find details when I get back I might post them here.

    In what way does Time Machine fail?
     
  8. dsemf macrumors regular

    Joined:
    Jul 26, 2014
    #8
    After booting in recovery mode (command-r), go to Utilities >> Terminal.

    At the prompt, enter diskutil list and press enter.

    Please supply the information for /dev/disk0.

    Also do the following commands:

    cd /Volumes
    ls -l

    Also supply this information.

    DS
     
  9. IA64 thread starter macrumors 6502

    Joined:
    Nov 8, 2013
    #9
    Hello,

    Thanks for the help, I am running bootcamp now, not possible to copy paste since the system is not booting.

    I can see all partitions and my MAC HD can be read under windows.

    [​IMG]

    Once I mount, all is OK.

    As for the errors, it's incorrect number of thread records
     
  10. dsemf macrumors regular

    Joined:
    Jul 26, 2014
    #10
    I realize that you cannot copy/paste, but we need to know what is really there from the Apple perspective, not Windows interpretation of it.

    DS
     
  11. DonMega macrumors regular

    Joined:
    Jul 8, 2007
    #11
    Sounds to me like Windows access to the OS X disk borked the filesystem. If DiskWarrior can't fix it, I'm afraid you might be out of luck... :(
     
  12. IA64, Nov 15, 2014
    Last edited: Nov 15, 2014

    IA64 thread starter macrumors 6502

    Joined:
    Nov 8, 2013
    #12
    Sorry but I slept yesterday because everything vanished.

    Before listing the volumes, I made a PRAM reset and guess what.... BOOTCAmp patition Disappeared from startup :)))))

    I can see the drive but the partition table is messed up.

    Now I literally lost everything. Lots of important files not yet backed up and system with 2 OS not running either.
     

    Attached Files:

  13. grahamperrin macrumors 601

    grahamperrin

    Joined:
    Jun 8, 2007
    #13
    IA64: after the invalid b-tree count, did you attempt a repair? Truly, that type of inconsistency can be very troublesome.

    Side note: in some situations, an attempt to repair by Recovery OS or OS X will be invisible.

    The phrase "incorrect number of thread records" is given by Apple fsck_hfs – you'll find it in http://www.opensource.apple.com/source/hfs/hfs-285/fsck_hfs/fsck_hfs_strings.c

    I doubt that Apple's software for Windows allows writing to HFS Plus.

    In what way is the table wrong?

    The earlier question: in what way does Time Machine fail?
     
  14. IA64 thread starter macrumors 6502

    Joined:
    Nov 8, 2013
    #14
    Hello, Please check both uploaded pictures. There is no MBR or maybe corrupted. Windows EFI boot doesnt exist anymore. Fdisk output is unexpected.

    Now Safe mode doesnt work as once it finishes fsck it shutdown.

    Single user mode not helpful

    Windows not booting - No boot device found

    Time machine restore is throwing incompatible system version

    Can things be worse? Dont wanna blame Yosemite but first time to see something similar in my last 30 years
     
  15. mtasquared macrumors regular

    mtasquared

    Joined:
    May 3, 2012
    #15
    If this happened to me I would be thinking there is something wrong with the SSD, not necessarily Yosemite, because the problem is affecting both OS's. I would remove that drive, stick it in an extra bay in someone's mac pro, and run recovery software. Maybe something like Drive Genius 3 or EaseUs SSD Drive recovery software. Then replace the drive, hopefully under warranty.
     
  16. IA64 thread starter macrumors 6502

    Joined:
    Nov 8, 2013
    #16
    I checked bad sectors and none were found. Its impossible to remove the drive on an iMac 2013 because of the glued screen
     
  17. grahamperrin macrumors 601

    grahamperrin

    Joined:
    Jun 8, 2007
    #17
    Maybe a hardware issue. Be prepared to perform a clean installation of Mavericks.

    IA64: without being hands-on, I had same suspicion as mtasquared. However you choose to proceed with the inconsistent file system, consider the possibility that hardware is failing.

    Maybe perform a block copy of the device, if you have a spare disk.

    OK. I haven't touched Boot Camp in years, so I'm not familiar with what's normal for a GPT in a Yosemite Boot Camp environment.

    I guess that you already have points of reference such as these:

    Recovering your GUID Partition Table (restoring the PMBR) - OnMac.net Forums (2006)

    How do I make my Boot Camp partition bootable again? – Super User (2012)

    Mavericks Destroyed Bootcamp Partition (2013)

    With every fsck_hfs attempt to repair, in such a problematic situation, there's the risk of making recovery more difficult.

    If your backup of Mavericks is good, you may wish to erase the installation of Yosemite then restore from the backup.

    Maybe perform a clean installation of Mavericks and allow Setup Assistant to migrate data from the backup.

    Hint: if you wish to verify the file system of the backup, do not rush to attempt any repair. Simply verify it.

    What did you use for that check?

    (An fsck_hfs check for bad blocks on a device will not check the physical disk in its entirety.)
     
  18. IA64 thread starter macrumors 6502

    Joined:
    Nov 8, 2013
    #18
    I logged in to Windows yesterday before the disaster and run from HDtune and verified sectors. Scanned the entire 512GB and nothing is damaged.

    I checked the SMART status and no failure whatsoever. I even went to disk utility and checked the Disk0 info, no sign of any error in the stats.

    Now I am using an old Win XP laptop. I don't care about OSX partition as much as Bootcamp for now as I need to repair that MBR in any way.


    I can secure erase the OSX partition and recover but downloading 4GB from the internet is around 5 hours work on an 8Mbps.

    I then need to download another 5GB ( Yosemite ) and install it.

    I feel like I need 4 days to restore everything assuming everything goes fine.


    I can't believe there is no easier way to fix that. On Windows back in time we used to type from bootable CD : fixmbr and problem solved.

    There is also and option to repair an installation without the need to download every freaking file on the internet over the Air.
     
  19. dsemf macrumors regular

    Joined:
    Jul 26, 2014
    #19
    Where you able to get a picture of the "diskutil list" output before doing the other activities?

    Have you applied the latest set of patches for Windows? If so, did OS X still work after doing so?

    DS
     
  20. IA64 thread starter macrumors 6502

    Joined:
    Nov 8, 2013
    #20
    Hello DS

    Actually the partitions are intact. There has been no lost partitions as far as I know. Only corrupted partition tables.

    Windows 8.1 Pro is always up-to-date with all patches installed. I have MacDrive installed on Bootcamp but it couldn't repair the HFS volume.

    I have Refind ( EFI boot manager ) installed not sure if the command line can help.

    One other thing. I might be able to repair the disk from another disk but I don't know where to find a bootable Image online for Mac .

    DiskUtil repairDisk /dev/diskX might be able to repair the partition table but can't be run on live system.

    DiskUtil under Recover mode won't accept blank DVDs to burn image from External disk, it's automatically ejected although tried two brands of disks but it was able to loan Movie DVDs etc...

    Any more ideas are much appreciated.
     
  21. IA64 thread starter macrumors 6502

    Joined:
    Nov 8, 2013
    #21
    OK some updates. I wiped all Mac HD and reinstalled Mavericks. It went well. I restored my files now from Time machine but Bootcamp still not seen.

    Anyone experienced can tell me how to restore the boot option to get Bootcamp running ( EFI ) ?

    Code:
    gpt show: disk0: Suspicious MBR at sector 0
          start       size  index  contents
              0          1         MBR
              1          1         Pri GPT header
              2         32         Pri GPT table
             34          6         
             40     409600      1  GPT part - C12A7328-F81F-11D2-BA4B-00A0C93EC93B
         409640  292968736      2  GPT part - 48465300-0000-11AA-AA11-00306543ECAC
      293378376    1269536      3  GPT part - 426F6F74-0000-11AA-AA11-00306543ECAC
      294647912       1944         
      294649856  682455040      4  GPT part - EBD0A0A2-B9E5-4433-87C0-68B6B72699C7
      977104896        131         
      977105027         32         Sec GPT table
      977105059          1         Sec GPT header
    

    Code:
    Disk: /dev/disk0	geometry: 60821/255/63 [977105060 sectors]
    Signature: 0xAA55
             Starting       Ending
     #: id  cyl  hd sec -  cyl  hd sec [     start -       size]
    ------------------------------------------------------------------------
     1: EE 1023 254  63 - 1023 254  63 [         1 -     409639] <Unknown ID>
     2: AF 1023 254  63 - 1023 254  63 [    409640 -  292968736] HFS+        
     3: AB 1023 254  63 - 1023 254  63 [ 293378376 -    1269536] Darwin Boot 
    *4: 07 1023 254  63 - 1023 254  63 [ 294649856 -  682455040] HPFS/QNX/AUX

    Code:
    dev/disk0
       #:                       TYPE NAME                    SIZE       IDENTIFIER
       0:      GUID_partition_scheme                        *500.3 GB   disk0
       1:                        EFI EFI                     209.7 MB   disk0s1
       2:                  Apple_HFS Macintosh HD            150.0 GB   disk0s2
       3:                 Apple_Boot Recovery HD             650.0 MB   disk0s3
       4:       Microsoft Basic Data BOOTCAMP                349.4 GB   disk0s4
    /dev/disk1
       #:                       TYPE NAME                    SIZE       IDENTIFIER
       0:     FDisk_partition_scheme                        *31.4 GB    disk1
       1:             Windows_FAT_32 UUI                     31.4 GB    disk1s1
     
  22. IA64 thread starter macrumors 6502

    Joined:
    Nov 8, 2013
  23. dsemf macrumors regular

    Joined:
    Jul 26, 2014
    #23
    Have you tried running Boot Camp Assistant and see what happens. It appears that the bootcamp partition is there so maybe it will cleanup things up. Then again, it might force you to start from the beginning of the process.

    Is there a reason that you are using Refind? I used it many years ago but it did not seem to get me anything so I stopped using it.

    DS
     
  24. IA64 thread starter macrumors 6502

    Joined:
    Nov 8, 2013
    #24
    I wish it was that simple, now I burned WIn8.1 installation to USB

    It cant repair the disk saying it's locked. I cant even reset the installation to clean install.

    Tried bootrec /fixboot /fixmbr / rebuildbcd but not helping.

    I think the EFI is messed up.

    Unless someone else has any idea, my only option now is to delete the whole Bootcamp partition and lose all the settings. Too much heartache.

    The good news is that I got rid of Yosemite and never gonna install it again.
    Im 100% sure that it messed up things after upgrade. Never ever had that much of headache with OSX/Bootcamp ever since I started using iMacs.

    Btw... gptsync / gdisk / testdisk and gparted did not help. Fdisk as well tried to fix the partition table by editing the MBR but nah...
     
  25. bluedoggiant macrumors 68030

    bluedoggiant

    Joined:
    Jul 13, 2007
    Location:
    MD & ATL,GA
    #25
    May I add that this thread is intense.

    I am very sorry for your problems.
     

Share This Page