Where does it get saved?

Discussion in 'Mac Basics and Help' started by Bulldog VII, Feb 26, 2016.

  1. Bulldog VII macrumors 6502

    Bulldog VII

    Joined:
    Jul 10, 2007
    Location:
    London
    #1
    Hi all

    When ever I save a word document from an email it goes to a wierd location that I have never actually managed to find on my imac?

    It looks like this before I change it to Desktop (see attached)

    I have tried searching for the file but can never find it, is there a way of (a) seeing where the files are & (b) changing to always go to my desktop

    Thanks

    Phil

    ps got a 2012 Imac 27" with Intel on OS 10.11.3
     

    Attached Files:

  2. BrianBaughn macrumors 601

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #2
    Looks like it's defaulting to one of the folders down inside the ~/Library/Mail folder. You can get there by, in the Finder, selecting the "Go" menu, holding down the "Option" key and selecting "Library".

    But, yeah, you don't want it defaulting to there. Is Mail>Preferences>General>Downloads folder: set to "Desktop"?

    Alternately, you can right click on an attachment (in the email itself) and save it to the Downloads folder.
     
  3. JohnDS macrumors 65816

    Joined:
    Oct 25, 2015
    #3
    Or drag and drop it from a message to whatever folder you want.
     
  4. Bulldog VII thread starter macrumors 6502

    Bulldog VII

    Joined:
    Jul 10, 2007
    Location:
    London
    #4
    Brian, thanks I can't seem to see the Library in the options field & I have reset my email preferences thanks
    --- Post Merged, Feb 26, 2016 ---
    These are my options on 'Go'
     

    Attached Files:

  5. CoastalOR macrumors 68000

    CoastalOR

    Joined:
    Jan 19, 2015
    Location:
    Oregon, USA
    #5
    You have to hold the option/alt key before selecting the Go drop down menu to see Library on the list. The Library is a hidden folder in your User folder.
     
  6. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #6
    I think the problem here is the way you are opening the files to begin with. It appears you are just double clicking the file from within the email message, then editing the document. Then when you tell it to save, it by default wants to save to the files current location... and this is the correct behavior.

    When you receive an email attachment, the Mail app saves the attachment in the user folder below. Triple click the line below in this message to select the whole file path, then right click, then in the Services menu select "Reveal in Finder." That will open Finder to the Mail downloads save folder. In that Mail Downloads folder you will see a bunch of long gibberish folders like the one starting with 3DD4 in your screenshot. Those folders is where Mail saves downloaded files, and this is where you are in effect editing the file from because you are double clicking the file from within the Mail app. Then when you go to save it correctly wants to save to the same folder the file is already in.

    You can avoid this issue by just dragging the file out of Mail onto the Desktop to begin with, then double click the file to work with it. Then when you go to save, it will save to the Desktop.

    Code:
    ~/Library/Containers/com.apple.mail/Data/Library/Mail Downloads/
    You can see what I mean here with this test I emailed to myself. This testfile is an image I sent myself then double clicked to edit in Preview app. If you hold the control key then click the file name in the top of the app, you can see the path where the file is stored in one of those gibberish folders I mentioned.

    Screen_Shot_2016-02-26_at_8_49_38_AM.png

    tl;dr There is nothing wrong here, you just need to drag the file out of Mail before you work on it.
     
  7. Bulldog VII thread starter macrumors 6502

    Bulldog VII

    Joined:
    Jul 10, 2007
    Location:
    London
    #7
    Thanks all

    Managed to find the files & delete them all now

    Phil
     

Share This Page