Where does text replacement work in Mavericks?

Discussion in 'OS X Mavericks (10.9)' started by rjleamaster, Nov 6, 2013.

  1. rjleamaster, Nov 6, 2013
    Last edited: Nov 6, 2013

    rjleamaster macrumors newbie

    Joined:
    Jan 26, 2012
    #1
    I decided to quit TextExpander and use the text replacement feature in Mavericks for my often-used snippets. But the text replacement is not working in Mail, which is one of the main apps I it for. Is this a bug in Mavericks or expected behavior? It works in Safari text editor apps.
     
  2. verwon macrumors 68030

    verwon

    Joined:
    Jul 26, 2011
    Location:
    Seattle
    #2
    You mean the shortcuts/substitutions, such as typing omw and it changes for you to On my way! ?

    Mine works fine in everything, check how you have them set up under substitutions on your Mac.
     
  3. rjleamaster thread starter macrumors newbie

    Joined:
    Jan 26, 2012
    #3
    Right, in System Preferences - Keyboard - Text. For some reason it is not working for me in Mail.
     
  4. verwon macrumors 68030

    verwon

    Joined:
    Jul 26, 2011
    Location:
    Seattle
    #4
    Odd! Mine works....which means I keep accidentally typing stuff I set up for business use to personal friends. LOL

    Did you check the list it make sure they're in there correctly?
     
  5. ph:l macrumors newbie

    Joined:
    Nov 8, 2013
    #5
    Hi, it doesn't work for me either and as you said the problem is limited to the Mail app. Maybe it's linked to the system… I have a MacBook Pro mid 2009.

    Any ideas?
     
  6. DJLC macrumors 6502a

    DJLC

    Joined:
    Jul 17, 2005
    Location:
    Mooresville, NC
    #6
    Did you monkey around in Mail's Edit menu to be sure it's enabled for that app?
     
  7. Keukasmallie macrumors regular

    Keukasmallie

    Joined:
    Jan 30, 2011
    Location:
    WNY
    #7
    Text replacement won't work for me in Mail either. I added the proper entries in System Preferences>Keyboard>Text; experimented w/ a blank email, but no worky. I checked Edit>Substitutions in Mail, found text substitution wasn't enabled, so I checked it; tried it again, no joy.

    I then enabled it, rebooted Mail, tried again, nothing.

    Please describe the specific steps necessary to enable text substitution in Mail on my 2011, MBP running the current Mavericks.

    Thanks for your help!
     
  8. rjleamaster thread starter macrumors newbie

    Joined:
    Jan 26, 2012
    #8
    Edit>Substitutions>Text Replacement

    I got it to work. I ticked the Text Replacement menu under Edit>Substitutions>Text Replacement and it is working now.
     
  9. ElectricSheep macrumors 6502

    ElectricSheep

    Joined:
    Feb 18, 2004
    Location:
    Wilmington, DE
    #9
    You can also right-click on any Cocoa-aware text field to enable/disable Text Substitution from there.

    [​IMG]
     
  10. tuqqer macrumors member

    Joined:
    Jun 28, 2005
    Location:
    Boulder, CO
    #10
    It's definitely a buggy feature, at least as of 4-19-2014.

    I'm running all latest updates (10.9.2), and even with checking the correct box in Substitutions for each app (and even running the Terminal command
    defaults write -g WebAutomaticTextReplacementEnabled -bool true
    ...and following Apple's guidelines here, I find some apps (like Messages/iChat) don't autofill all of my text expansions, where other apps (like Mail) expand that same those same ones that don't work.

    I stopped using Spell Catcher and TypeIt4Me when I upgraded to Mavericks, in hopes that its built-in text expander would do the job. It does for most things, but it's still not fully cooked.
     
  11. MDJCM macrumors regular

    MDJCM

    Joined:
    Sep 12, 2009
    Location:
    UK, South
    #11
    Still buggy on latest Mavericks.

    Shame it only works some of the time unlike on the iPhone
     
  12. ricede macrumors regular

    ricede

    Joined:
    Aug 16, 2010
    Location:
    Inside
    #12
    I just tried it & it works fine for me in Mail on 10.9.5
    However - i just noticed that in Syst Prefs/keyboard/text the default list is no longer there. The one that used to contain items such as 1/2 3/4 etc
    Is that just something missing in mine or is it no longer a feature of 10.9.5 ?
    Also i couldn't find 1/2 3/4 etc under the Character Viewer menu either :confused:
     
  13. mac65 macrumors member

    mac65

    Joined:
    Mar 31, 2009
    Location:
    Munich, Germany
    #13
    Well, it used to work for me until recently (maybe when I upgraded from 10.10.4 to 10.10.5 or a little time after that). Before it worked at least in TextEdit and in Spotlight's quick entry form (ctrl-space) but now it suddenly works nowhere any more. I don't have any clue what could have changed.
    I double checked the "Text Replacement" is checked.

    Anyone else had this happen?
     

Share This Page