Where iMessage lacks logic

Discussion in 'iOS 5 and earlier' started by DeMatthew, Oct 18, 2011.

  1. DeMatthew macrumors newbie

    Joined:
    Oct 18, 2011
    #1
    Hi guys.

    I stumbled upon this problem:

    My dad has an iPhone 3GS and an iPad.

    - The iPhone has during his working shift no internet access (he doesn't want to pay for a data plan)
    - His iPad is at home with WiFi access

    If I wish to contact him by texting him, it will send out an iMessage. But because it will be received on his iPad, I will not be able to resend it as a text message (SMS), which means he will not receive it at work, or when he's out with friends or with my mum,... whenever he's not at home connected to WiFi.

    This same situation is when somebody's on a holiday in another country and doesn't wish to roam, while his iPad is at home or at the hotel connected to the WiFi.

    Any ideas?
     
  2. garethjs macrumors 6502

    Joined:
    Nov 11, 2008
    #2
    Stop sending it to him via his apple ID.

    Send it to his mobile # and it won't transfer to the iPad.
     
  3. DeMatthew thread starter macrumors newbie

    Joined:
    Oct 18, 2011
    #3
    And how exactly do I do that? If I type in his number, it will become his contact and send out as an iMessage. Or is there a feature I might have missed?
     
  4. Acronym macrumors 68000

    Joined:
    Apr 26, 2008
    #4
    it will send as an iMessage, that is one of the way's a person can be reached at is their phone number.
     
  5. DeMatthew thread starter macrumors newbie

    Joined:
    Oct 18, 2011
    #5
    Okay, but I don't want that. I want it to be a text message because when it's an iMessage, his iPad will intercept it and his iPhone won't receive it. Or am I missing the point here?
     
  6. Acronym macrumors 68000

    Joined:
    Apr 26, 2008
    #6
    if you text his phone number I believe he will receive it, but being as I do not own iPad/iPod I cannot test this feature myself.
     
  7. Puonti macrumors 6502a

    Joined:
    Mar 14, 2011
    #7
    When you start typing your dad's name into the recipient field and his available contact information comes up (judging by what you've said, at the very least one phone number and one e-mail address), which ones have a blue chat bubble icon next to them?
     
  8. boss.king macrumors 68040

    boss.king

    Joined:
    Apr 8, 2009
    #8
    I had this very problem earlier OP, I couldn't reach my mom because her iPad was intercepting the iMessages. It's dumb that it just assumes you want to use iMessages rather than just offering a choice. The only workaround I found is to switch off data (and wifi) before you send it, which is crap since they don't even give you any damn toggles, you have to delve around in setting for that.
     
  9. Fliesen macrumors 6502a

    Fliesen

    Joined:
    Mar 30, 2010
    Location:
    Austria
    #9
    your iPad doesn't intercept messages sent to the phone number.

    even if the phone number's also registered as an iMessage contact.
    the iPad ONLY receives iMessages sent to the appleID
     
  10. boss.king macrumors 68040

    boss.king

    Joined:
    Apr 8, 2009
    #10
    Then I don't know why the iPad kept intercepting them. I just kept texting in the threaded message that I've always used (to a phone number). Possibly a bug?
     
  11. miniConvert macrumors 68040

    miniConvert

    Joined:
    Mar 4, 2006
    Location:
    Kent, UK - the 'Garden of England'.
    #11
    You can switch off iMessage in Settings > Messages if you really don't want it to get used.

    But yeah, as others have said, providing you're messaging the mobile number, not the Apple ID, it won't get intercepted by the iPad. It'll try and deliver as an iMessage to the mobile number, but if it can't it'll revert to a regular SMS. This has happened a few times for me when iMessaging people that move out of reach of data.

    You might even want to split the contact in two if things are getting really confusing; have one that only contains the mobile number.

    It might be worth checking the iPad to ensure that in Settings > Messages it's only associated with the Apple ID and not the phone number (though the latter would be impossible I'd have thought).
     
  12. sn macrumors 6502

    Joined:
    Apr 22, 2011
    #12
    Settings > Messages > Turn iMessage Off

    I've done this because I have unlimited texts so would rather use them than my limited data.


    e: oh, beaten to it!
     
  13. boss.king macrumors 68040

    boss.king

    Joined:
    Apr 8, 2009
    #13
    I'll try get her to check that next time I talk to her (we live in different countries), and post back if I find out what was happening.
     

Share This Page