Where is my hard drive space going? Help

Discussion in 'macOS' started by chequepoint, Dec 4, 2007.

  1. chequepoint macrumors member

    Joined:
    Dec 4, 2007
    #1
    Relatively new convert to mac.
    20" aluminum imac. 4GB of ram. Its not my primary machine, just my video editing machine. Most of the time I have a macbook. I went to my machine today, and it said I have no HD space on the boot HD. All my video files are on external HD's..

    I emptied the trash, and it cleared up about 80GB, which is rapidly declining. Something is writing massive amounts of info to my HD, and I have no clue what it is.

    Help. Don't even know where to start to troubleshoot.
     
  2. superleccy macrumors 6502a

    superleccy

    Joined:
    Oct 31, 2004
    Location:
    That there big London
    #2
    A tool such as one of these will be your friend...

    Disk Inventory X (prettier)
    Omni Disk Sweeper(faster)

    There's another one too that I can't remember the name of. It's like Omni Disk Sweeper, but you don't have to register to use the delete button.

    Remember that none of these tools will see files outside of the account you're running it from.

    SL
     
  3. chequepoint thread starter macrumors member

    Joined:
    Dec 4, 2007
    #4
    Progress..

    Omni Disk found this..

    under a folder marked "private" which I'm assuming is hidden as I can't see it in finder.. Private->var->log->samba->log.smbd

    log.smbd is 171.8GB!

    That is where my missing hard drive space is..
    Now.. two questions..
    1) If i delete this, what will happen?? I have a lot of important stuff on here and I'm trying to avoid a system crash, or having to do some kind of emergency backup on a failing system

    2) What could possibly be causing this?? It says that the folder "Samba" is part of package "BaseSystem"

    Help
     
  4. plinden macrumors 68040

    plinden

    Joined:
    Apr 8, 2004
    #5
    smbd is the filesharing daemon. Do you need filesharing enabled? Are you accessing the Mac from another computer? I would turn it off unless you need it. And you should be able to delete the log file without causing any problems.

    But just out of curiousity, what's being logged to the smbd.log file?
     
  5. Sun Baked macrumors G5

    Sun Baked

    Joined:
    May 19, 2002
    #6
    Use console.app and look at the log, most likely there is something wrong with the samba setup -- which is why the log is getting big so fast.
     
  6. chequepoint thread starter macrumors member

    Joined:
    Dec 4, 2007
    #7
    I do file share between it and my laptop, have .mac running, etc.

    The log appears to be this over and over again:
    "[2007/12/04 16:28:32, 0, pid=15153] /SourceCache/samba/samba-187/samba/source/smbd/server.c:eek:pen_sockets_smbd(468)
    open_sockets_smbd: accept: Too many open files
    [2007/12/04 16:28:32, 0, pid=15153] /SourceCache/samba/samba-187/samba/source/smbd/server.c:eek:pen_sockets_smbd(468)
    open_sockets_smbd: accept: Too many open files
    [2007/12/04 16:28:32, 0, pid=15153] /SourceCache/samba/samba-187/samba/source/smbd/server.c:eek:pen_sockets_smbd(468)
    open_sockets_smbd: accept: Too many open files
    [2007/12/04 16:28:32, 0, pid=15153] /SourceCache/samba/samba-187/samba/source/smbd/server.c:eek:pen_sockets_smbd(468)
    open_sockets_smbd: accept: Too many open files
    [2007/12/04 16:28:32, 0, pid=15153] /SourceCache/samba/samba-187/samba/source/smbd/server.c:eek:pen_sockets_smbd(468)
    open_sockets_smbd: accept: Too many open files
    [2007/12/04 16:28:32, 0, pid=15153] /SourceCache/samba/samba-187/samba/source/smbd/server.c:eek:pen_sockets_smbd(468)
    open_sockets_smbd: accept: Too many open files
    [2007/12/04 16:28:32, 0, pid=15153] /SourceCache/samba/samba-187/samba/source/smbd/server.c:eek:pen_sockets_smbd(468)
    open_sockets_smbd: accept: Too many open files
    [2007/12/04 16:28:32, 0, pid=15153] /SourceCache/samba/samba-187/samba/source/smbd/server.c:eek:pen_sockets_smbd(468)
    open_sockets_smbd: accept: Too many open files
    [2007/12/04 16:28:32, 0, pid=15153] /SourceCache/samba/samba-187/samba/source/smbd/server.c:eek:pen_sockets_smbd(468)
    open_sockets_smbd: accept: Too many open files
    [2007/12/04 16:28:32, 0, pid=15153] /SourceCache/samba/samba-187/samba/source/smbd/server.c:eek:pen_sockets_smbd(468)
    open_sockets_smbd: accept: Too many open files
    [2007/12/04 16:28:32, 0, pid=15153] /SourceCache/samba/samba-187/samba/source/smbd/server.c:eek:pen_sockets_smbd(468)
    open_sockets_smbd: accept: Too many open files"

    And occasionally this:
    " [2007/12/04 16:28:32, 0, pid=15153] /SourceCache/samba/samba-187/samba/source/lib/debug.c:reopen_logs(625)
    Unable to open new log file /private/var/log/samba/log.smbd: Too many open files
    [2007/12/04 16:28:32, 0, pid=15153] /SourceCache/samba/samba-187/samba/source/lib/debug.c:reopen_logs(625)
    Unable to open new log file /private/var/log/samba/log.smbd: Too many open files
    "

    I'm deleting it to buy myself time, but need to know how to stop it.
     
  7. plinden macrumors 68040

    plinden

    Joined:
    Apr 8, 2004
    #8
    Try switching off file sharing, remove the log file, and switch it back on. Keep an eye on the log file.

    Also, this is highly unlikely, but are you sure the port isn't open to the internet, allowing a brute force attack on it?

    Edit: hold on, are you filesharing to a Windows machine? If not, you don't need samba enabled.
     
  8. SawTooth500 macrumors member

    Joined:
    Nov 9, 2007
    Location:
    Florence, Arizona
    #9
    Do you have Time Machine enabled in the "System Preferences"?
    If so turn it off. Time Machine eats huge humongus extremely large amounts of space on the hard drive in no time at all.:eek:
     

Share This Page