Where is my HD gone?

Discussion in 'Mac Basics and Help' started by digitalpunkass, Oct 13, 2009.

  1. digitalpunkass macrumors newbie

    Joined:
    Oct 13, 2009
    #1
    I've had an intermittent problem with my ibook G4 1.2 Ghz 0SX 10.3 for awhile. When I boot up i get the flashing finder folder & question mark. My ibook rarely leaves my desk but when it does get carried around the problem occurs. This made me think something could be loose inside. So the solution I've used to fix it is to give it a shake-about and usually after 6-7 boot up and shakes attempts it finds the HD and boots up.

    I recently bought a used macbook and decided to sell the ibook so (not wanting to sell it with this problem) replaced the HD with a new 120gb one. It booted up fine. I even shook it about and booted it up a few times and had no problems. Now just when I thought it was fixed and I have found a buyer for it the problem came back!!! (and shaking it doesn't fix it now)

    Can it be anything else other than the HD causing this problem?

    I have:
    - Reset Pram and nvram
    - taken out 3rd party Ram chip
    - It can start up from install disc but HD doesn't show up so can't run disc utility.


    Thanks for any suggestions!
     
  2. BlueRevolution macrumors 603

    BlueRevolution

    Joined:
    Jul 26, 2004
    Location:
    Montreal, QC
    #2
    The first thing I'd check is the drive cable. Do you ever have trouble with the optical drive too?
     
  3. digitalpunkass thread starter macrumors newbie

    Joined:
    Oct 13, 2009
    #3
    No never had any trouble with optical drive.
     
  4. digitalpunkass thread starter macrumors newbie

    Joined:
    Oct 13, 2009
    #4
    Its was the cable after all. I replaced it and taped it down more securely and have had no problems with it thus far.....fingers crossed!

    Thanks for the advise! :D
     

Share This Page