Where is the fix for The Witcher (Steam) to work on 10.8.2???

Discussion in 'Mac and PC Games' started by 50548, Oct 17, 2012.

  1. 50548 Guest

    Joined:
    Apr 17, 2005
    Location:
    Currently in Switzerland
    #1
    The update for the non-Steam version is already out - what about the same thing for those who've bought this on Steam?

    Right now, the game does NOT work with 10.8.2...at all. What gives?
     
  2. laetusviator macrumors member

    laetusviator

    Joined:
    May 31, 2012
    #2
    Yeah, it can take longer for patches to come out on Steam. Always annoying.
     
  3. Dirtyharry50 macrumors 68000

    Dirtyharry50

    Joined:
    May 17, 2012
    #3
    Maybe you've already read the latest posts in the Steam forum for the game as I just did but just in case...

    I got the impression that if you verify the game cache, this will cause Wineskin to prompt you to download two needed updated files and then the game will run.

    I just glanced over the posts so you might want to take that advice with a grain of salt but it wouldn't hurt to try it. That it is certainly not as elegant as an automatic patch to just fix the game but if it works, that would be nice.
     
  4. 50548 thread starter Guest

    Joined:
    Apr 17, 2005
    Location:
    Currently in Switzerland
    #4
    Nope, verifying the cache doesn't trigger the action above - it's up to Steam to fix the problem.
     
  5. tuncer macrumors member

    Joined:
    Mar 19, 2008
    #5
    A DRM free version is coming to Macgamestore.com soon (along with the launch of Mac support at gog.com). Witcher 2 is close behind as well :)
     
  6. Warhawk15 macrumors regular

    Warhawk15

    Joined:
    Feb 1, 2012
    #6
    It didn't work for me either before the latest update, last week I think?

    This worked for me, in the steam forums.
    "NOTE: Before you do these steps I recommend going into steam right-click the witcher and select "Properties" then goto "Local Files" tab and click "Verify Integrity Of Game Cache" and let it fix any missing/changed files it finds.

    Now you can start. It is long list if steps but actually it is very very easy.

    1- Goto http://wineskin.urgesoftware.com/tiki-index.php and download the latest Wineskin winery (as of now it should be v1.7) and install it on you mac.

    2- Goto http://xquartz.macosforge.org/trac/wiki/X112.7.4 download latest XQuartz and install it on your mac.

    3- Run Wineskin winery and download the latest wine engine (for now it is WS9Wine1.5.13) you do this by clicking the "+" button and select the engine and then click "Download and Install".

    4- Also on the same main screen for Wineskin Winery make sure it says the wrapper is Wineskin-2.5.8 (the latest as of now).

    5- Now from the same main screen for Wineskin Winery select "Create New Black Wrapper".

    6- When it asks about the wrapper name it does not matter what you call it just click ok to continue.

    7- Wait for it to create the wrapper and click cancel for both Mono and Gecko when it asks you if you want to install them.

    8- When it finishes creating the wrapper it will show a dialog saying "Wrapper creating finished" now click the "View wrapper in finder" button. This should open the finder and show you the wrapper app.

    9- Right click the wrapper app and select "Show package contents". Now leave this finder window open as it is and open another window (press Cmd+N to open one quick).

    10- In the new finder window press "Shift+Cmd+G" and paste this path "~/Library/Application Support/Steam/SteamApps/common/the witcher enhanced edition" in the goto text box.

    11- You should now be in the Witcher steam folder and will be able to see "The Witcher" app.

    12- Right click the "The Witcher.app" and select "Show package contents".

    13- Go back to your other Finder window (where you have the contents of the wrapper shown) and copy the "wineskin.app" file from there to the other finder window (the one with the contents of the witcher app).

    14- Run the wineskin.app (the one that you just copied) from inside the Witcher.app. It should give you 4 buttons of options select "Advanced" then select the "Tools" tab and click "Change Engine used". Make sure "WS9Wine1.5.13" engine is select if not select it from the drop menu and then click "Ok". Wait for it to finish changing the engine.

    15- Last step from the previous screen (the one with the tab "Tools") now select the tab "Options" and check-on the last checkbox called "Force use of system installed XQuartz ..."

    Close wineskin and go run the witcher normally and it should now run."

    However right after doing this, they updated the game on steam and now it works fine without changing anything.
     
  7. doh123 macrumors 65816

    Joined:
    Dec 28, 2009
    #7
    I don't get why you'd want to use XQuartz...

    If you just get Wineskin 2.5.8 and click on the "update wrapper" button, you can update it to Wineskin 2.5.8 and it will then run fine on OS X 10.8.2+ and 10.7.5+... no need for XQuartz at all.
     
  8. 50548 thread starter Guest

    Joined:
    Apr 17, 2005
    Location:
    Currently in Switzerland
    #8
    I tried all of the above and it DID NOT work - gonna wait for the official fix, I guess...
     
  9. tuncer macrumors member

    Joined:
    Mar 19, 2008
    #9

Share This Page