Where'd the rest of my SD card go?

Discussion in 'MacBook Air' started by imrazor, May 6, 2019.

  1. imrazor macrumors regular

    imrazor

    Joined:
    Sep 8, 2010
    Location:
    Dol Amroth
    #1
    I have a 128GB microSD card that I had actually installed a bootable copy of Mojave on. This worked great during my upgrade to a 512GB Intel 760p SSD. I was able to just use Migration Assistant to pull my data from the SD card, and had a very smooth transition.

    However, I tried to add a exFAT partition so I could share data between OS X and Boot Camp. The exFAT partition is still there, but the Apple partition completely vanished. I now have a 128GB SD card with only a 16GB exFAT partition accessible to both Windows and OS X.

    Screen Shot 2019-05-06 at 7.13.24 PM.png Screen Shot 2019-05-06 at 7.13.53 PM.png

    As you can see from the screen shot, Size is 128GB but I cannot see any other free space or partitions. The exFAT partition cannot be increased from 16GB.

    Where'd my other 100GB+ go?

    EDIT: diskutil list shows the following:

    Code:
    /dev/disk2 (internal, physical):
       #:                       TYPE NAME                    SIZE       IDENTIFIER
       0:      GUID_partition_scheme                        *127.9 GB   disk2
       1:                        EFI EFI                     209.7 MB   disk2s1
       2:       Microsoft Basic Data Share                   16.5 GB    disk2s2
     
  2. uniquexoxo macrumors member

    uniquexoxo

    Joined:
    Aug 27, 2018
    Location:
    South East Asia
    #2
    This is probably worth more posting in the Apple Stack Exchange site
     
  3. DeltaMac macrumors G3

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #3
    Quickest fix should be to erase the SD card (the one named Apple SD Card Reader Media). That would remove/reset all partitions on the drive. Yes, that removes anything that is now on the card.
     
  4. imrazor thread starter macrumors regular

    imrazor

    Joined:
    Sep 8, 2010
    Location:
    Dol Amroth
    #4
    @DeltaMac Yep, erasing the SD card and re-partitioning it allowed me to access all the space on the microSD card. I *think* what happened is that I originally partitioned it with diskutil and only bothered to create one partition instead of using all the available space. For some reason, that confused Disk Utility and instead of showing unallocated free space, just showed the one 16GB shared partition.

    That's my theory anyway...
     

Share This Page

3 May 6, 2019