Wheres my Printer? Not on the list.

Discussion in 'Mac Basics and Help' started by seasomneviits, May 1, 2007.

  1. seasomneviits macrumors newbie

    Joined:
    May 1, 2007
    #1
    I just got a Macbook pro and a HP All-In-One PhotoSmart c3180 printer. I tried to set it up with the following steps.

    Step 1: Install drivers on mac, connect to mac, test. No problems
    Step 2: Install drivers on PC desktop, connect to PC, test. No problems
    Step 3: Share the printer that's connected via USB to the PC. No problems
    Step 4: Add networked printer to printer list on mac. Found on network. No problems.
    Step 5: Attempted to print apples webpage from the mac. 375 pages of junk.

    My conclusion: Driver error; i installed and tested with the mac wired in, so i assume the problem was when i added the printer. I backstepped and saw that the printer was added as "Generic PostScript Printer". I went to change this and the first option is "manufacturer". HP; piece of cake. But my printer isn't on the list; in fact, nothing even similar to my printer is on the llist.

    Apple told me "it's HP's fault call them". HP told me "it's not possible, give up".

    So how do i get my printer on the list, and can this even be done?

    P.S. it's a wireless network.
     
  2. skwij macrumors 6502

    Joined:
    Apr 10, 2006
    Location:
    Belleville, ON, Canada
    #2
    Whe you select "Print" do you get a dialogue box where you select the printer? You "should" see the printer under SHARED PRINTER. Be sure and select it before you attempt to print. Make sure the selection "sticks". The first couple times I tried this, my HP printer didn't show, and it didn't "select" after I'd selected it.

    [​IMG]

    All good now though, after doing it a couple of times. It worked the very first time when printing from Safari rather than Firefox.

    I haven't tried printing a word document yet, as my files are on the desktop Mac, not the Macbook. Sorry if this doesn't help out.
     
  3. seasomneviits thread starter macrumors newbie

    Joined:
    May 1, 2007
    #3
    The problem isn't getting it on the list, the problem is that when i add it as a shared printer it goes on as a "Generic PostScript Printer", which i think is causing it problems...
     
  4. deanops macrumors regular

    Joined:
    Jan 16, 2007
    Location:
    Melbourne, Australia
    #4
    im having the same problem with the same printer... what do i need to do.. i am a total noob at this and wireless,,, new to mac too... help please...
     
  5. psyqd macrumors newbie

    Joined:
    Jun 13, 2007
    #5
    Ppc?

    I've had this problem quite often. It's almost certainly a driver issue. Specifically, the driver is PowerPC only, not Universal. (If the printer was before January 2006, this is almost certainly the explanation). To fix it, open the Printer Setup Utility using Rosetta (Get Info > Open using Rosetta). The driver should appear then.

    PS: You'll always be able to print, but you can only get advanced, printer-only features if you're using a non-Universal app or an app through Rosetta.

    Hope this helps! :D
     
  6. deanops macrumors regular

    Joined:
    Jan 16, 2007
    Location:
    Melbourne, Australia
    #6
    huh....? sorry i dont quite understand:eek: ... this printer would have had to have been made recently, its an all in one scan print copy... i got it on saturday... help... a bit more expalining...
     

Share This Page