Which version

Discussion in 'iMac' started by TomT321, Sep 15, 2009.

  1. TomT321 macrumors member

    Joined:
    Sep 14, 2009
    #1
    In an earlier post I asked about upgrading my first generation G5 with a 1.8 Ghz single core processor from Tiger to Leopard. I was told that because my processor is not intel that I can not go beyond Leopard to Snow Leopard. However I have noticed that there seem to be different versions of Leopard and I would appreciate it if some one could tell me which version is needed for my specific IMac. I was also told that I should upgrade my Ram, which now stands at 768 MB, am I better off to just pull the 256 and replace with another 512 or go with a 1 Gig in addition to the 512? :confused:
     
  2. iMJustAGuy macrumors 68020

    iMJustAGuy

    Joined:
    Sep 10, 2007
    Location:
    Beach, FL
    #2
    I am pretty sure there is only one version of leopard and I don't really use OS X but I am pretty certain that if it IS RUNNING LEOPARD already AND an intel processor than it will be able to run Snow Leopard. I have an iMac G3 *lol* and it cannot take anything leopard or higher.. Im thinking it requires an 88mhz processor.....maybe...?
     

Share This Page