Which Xcode To Use On Lion?

Discussion in 'Mac OS X Lion (10.7)' started by Fazzl, Jul 2, 2011.

  1. Fazzl macrumors 6502a


    Aug 13, 2007
    I just installed the GM Lion update but it's saying my xcode is too old version. I have 4.0.2. I'm confused, do I need to download 4.2 beta 2 or the 4.1 preview? And is there any way I can still submit apps using either of these to the app store?
  2. merrickdrfc macrumors 6502


    Jan 8, 2011
    You need Xcode 4.2 DP 2 (Lion version)
  3. haravikk macrumors 65816

    May 1, 2005
    Is there any estimate on when this will be ready, and why won't other versions run? This will be a deal-breaker on Lion for me if I can't use XCode right away, so I'll have to wait.

    I was thinking of waiting anyway, but it seems silly that XCode 4, which wasn't released that long ago, won't run for some silly reason?
  4. merrickdrfc macrumors 6502


    Jan 8, 2011
    Most probably when Lion gets released, an update for Xcode 4 will be on the MAS for user's to allow Xcode 4 to run on 10.7.

    As it stands, Lion has still not been released, and the Xcode 4.2 beta is for the iOS 5 SDK beta, its primary purpose being for developers to get their apps ready for both systems.

    I'm guessing you haven't got a paid iOS developer account?
  5. Kahnyl macrumors 68000

    Feb 2, 2009
    From the notes...

  6. vsebastian macrumors newbie

    Nov 23, 2009
    now that Lion is out, can you use Xcode 4.2 DP 3 to submit apps?
  7. mrapplegate macrumors 68030

    Feb 26, 2011
    Cincinnati, OH
    You can only use Xcode 4.1 Posted Date: Jul 20, 2011
    Build: 4B110
    Included iOS SDK: iOS 4.3
    Included Mac SDK: Mac OS X 10.7

    To submit Lion Apps. It was released via the App store and the link on the dev center links to the App store build.
    The Xcode 4.2 I think is for iOS, and you can't submit Lion Apps with it.
  8. Madd the Sane macrumors 6502a

    Madd the Sane

    Nov 8, 2010

Share This Page