While restoring folder, Time Machine external drive constantly ejects

Discussion in 'Mac Basics and Help' started by The3rdMan, May 28, 2014.

  1. The3rdMan macrumors newbie

    Joined:
    Dec 22, 2008
    #1
    The internal drive holding all my iPhoto files died last week so I purchased a new, larger drive. Formatted the new drive this morning, tried to restore the iPhoto library from Time Machine but when it gets to around 20 GBs out of the 280 GB folder I get error messages that the disk (the external drive with TM on it) was improperly ejected and that the copy can't be finished. I tried this multiple times and am getting very frustrated. Any advice would be appreciated.
     
  2. essbeep macrumors newbie

    Joined:
    Apr 13, 2015
    #2
    Drive ejecting during Time Machine or other Backup Retrieval

    :) SOLUTION FOUND--- FINALLY:)

    I tried every which way but loose to do a full backup restore after my MacHD failed. They installed a new HD and told me to just boot up and restore.

    Ha! No chance. I had both Time Machine backup and also a WD smartware back up and every single time, right before the end, I would get the "disk improperly ejected" message....!

    I finally called Apple and asked if they still had my "semi-failed" drive so I could retrieve files manually by casing the old external drive.

    The tech that I talked to was a true "genius."

    I told him all the tedious steps I went through for two straight days and he asked:

    When you connected the External Drive -- did you connect it to the same USB port?


    Oh....wow....... ! I didn't know! I use all the ports since I keep three backups --the WD smartware, Time Machine, and a partial/daily drag n' drop for JOBS.


    So --- I started over disconnecting all other drives and one at a time, I plug in the USB cable of the SOURCE backup external to each USB port, run back up, and fail, change port, fail, and finally .... VOILA!!!! I found the "magic button."


    My backup went through and I am a happy camper.


    Finally I can sleep. :cool:
     

Share This Page