While typing an SMS, periods and capitalization are being added automatically!!

Discussion in 'iOS 5 and earlier' started by cybrscot, Feb 4, 2012.

  1. cybrscot macrumors 6502

    cybrscot

    Joined:
    Dec 7, 2010
    Location:
    Somewhere in Southeast Asia
    #1
    Okay, this is pretty buggy. I'm going to start calling them "Applesoft" if they don't get their act together!

    I have an iPhone 3GS that is not and never has been jail broken. I upgraded to the latest IOS 5.0.1 about 3 days ago.

    While I'm typing SMS messages, especially while typing quickly, the IOS is automatically inserting a "." where it's not wanted and not the letter that I typed. Thus, the second letter of my intent is then capitalized after the period. So the word is not what I typed and there is a period in the middle of the sentence. And because the word is not what I typed, because the first letter was replaced by a period, the automatic word suggestion now tries to replace my intended word with something totally different! Also, I noticed that while typing slowly, if I press the space bar twice I also get an unwanted ".", instead of two spaces.

    Please keep in mind, that although I'm texting quickly, there is no "." key on the primary QWERTY keyboard, so I'm not accidentally hitting it. I've replicated this issue numerous times.
     
  2. DefBref macrumors 6502

    Joined:
    Feb 26, 2011
    #2
    Settings - general - keyboard - switch "." Shortcut to off, also switch Auto capitalization off as well if you want.
     
  3. hector4drake macrumors newbie

    Joined:
    Feb 3, 2012
    Location:
    Japan
    #3
    That`s right. It isn`t a "bug"
     
  4. DefBref macrumors 6502

    Joined:
    Feb 26, 2011
    #4
    Yeah not a bug, I find it pretty useful for full stops. Plus on the ipad its handy to do a two finger tap on space bar for full stop.
     
  5. YMark macrumors 6502a

    YMark

    Joined:
    Nov 7, 2008
    Location:
    Arizona
    #5
    BOTH of you should read what the OP wrote. Because your replies are NOT addressing the issue.
     
  6. rocknblogger macrumors 68020

    rocknblogger

    Joined:
    Apr 2, 2011
    Location:
    New Jersey
    #6
    Most likely they do address the issue. When the OP types fast he more than likely is tapping the space bar twice hence the period. It happens to me too.
     
  7. cybrscot thread starter macrumors 6502

    cybrscot

    Joined:
    Dec 7, 2010
    Location:
    Somewhere in Southeast Asia
    #7
    Yeah, I could be light touch "double tapping" the space bar as I type. I followed the instructions for the settings and turned off that feature. My first couple messages seem okay. So maybe that was the problem!

    Sorry I possibly incorrectly identified that as a bug. I think the installation of the new IOS changed some things that I previously didn't use, such as that feature.

    That might have done the trick!

    Thanks for all the help everybody! I'll keep you posted if it doesn't work out!
     
  8. DefBref macrumors 6502

    Joined:
    Feb 26, 2011
    #8
    Neither is yours, at least I suggested something, which may actually have helped the op.
     

Share This Page