white iMac wont eject dvd

Discussion in 'iMac' started by nikmash232, Aug 17, 2010.

  1. nikmash232 macrumors newbie

    Joined:
    Jun 30, 2010
    #1
    So i got an iMac off of craigslist and didnt get it with the apple keyboard and mouse. It also came with windows 7 so i put in snow leopard deleted the windows 7 partition and then the installation froze so i manually turned it off. U tried to install again and it froze now i dont know what to do and ive tried every method to eject the dvd. Im thinking of opening it up you guys have any ideas?
     
  2. nikmash232 thread starter macrumors newbie

    Joined:
    Jun 30, 2010
    #3
    When i tried holding down the mouse button while turning on the mac itt sounded lile the mac was trying to eject the disc but it didn't. Also i dont have a command key so cant try that option.
     
  3. spinnerlys Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
    #4
    Try the Windows key (between CTRL and ALT).

    [​IMG]
     
  4. nikmash232 thread starter macrumors newbie

    Joined:
    Jun 30, 2010
    #5
    Tried it didn't work.

    So I got mac osx to load up. And the drive reads the disc fine but whatever I do it won't eject I tried every method.
     
  5. joescamp7 macrumors newbie

    Joined:
    Sep 22, 2010
    #6
    iMac wont eject disc

    I had the same problem, now solved. Turn off the iMac by holding button on back. Then, turn it on, and then hold the F12 button. IMac will automatically eject the disc and not try to read it. Good luck!
     

Share This Page