White Macbook - Not Finishing Charge Cycle - Snow Leopard

Discussion in 'MacBook' started by Jordz, Aug 30, 2009.

  1. Jordz macrumors member

    Jordz

    Joined:
    Aug 16, 2008
    Location:
    England, U.K
    #1
    I installed Snow Leopard last night on my macbook, the battery was fully charged and the magsafe light was green. When I booted up snow the light was orange and it said in the top bar 99%. I thought I'd run the battery down and back up again just to be sure and still the macbook stays at 99% and wont go green. Its been like this for hours.
    Screen shot 2009-08-30 at 17.53.19.png

    Anyone help would be appreciated.

    Thanks,

    Jordan
     
  2. NewMacbookPlz macrumors 68040

    NewMacbookPlz

    Joined:
    Sep 28, 2008
    #2
    Pull the adapter out, use it a little and plug it back in.

    Shouldn't really be a software issue. Also, try rebooting or resetting the SMC.
     
  3. Jordz thread starter macrumors member

    Jordz

    Joined:
    Aug 16, 2008
    Location:
    England, U.K
  4. macintoshSL macrumors member

    macintoshSL

    Joined:
    Mar 17, 2008
    #4
    So what did you end up doing to fix it because I'm about to install snow leopard
     
  5. Jordz thread starter macrumors member

    Jordz

    Joined:
    Aug 16, 2008
    Location:
    England, U.K
    #5

    I switched it to the small plug adapter and it seemed to do the trick. Which is very weird considering they both should do the same thing.

    Jordan
     
  6. brn2ski00 macrumors 68020

    brn2ski00

    Joined:
    Aug 16, 2007
    #6
    my aluminum MB is having the same issue - the light is orange on the power adapter and it never reaches a full charge.
     
  7. Bill Gates macrumors 68020

    Bill Gates

    Joined:
    Jun 21, 2006
    Location:
    127.0.0.1
    #7
    I doubt that that's what fixed it. Probably the action of unplugging it and plugging it back in is what did.
     

Share This Page