White Screen Problems

Discussion in 'iPod touch' started by PercussiveScruf, Sep 20, 2011.

  1. PercussiveScruf macrumors newbie

    Joined:
    Sep 20, 2011
    #1
    Hi guys, I've been using this site for a while, but never actually felt the need to post due to the large amount of issues and fixes out there on these forums. Originally, I dropped the iPod into a glass of water. I pulled it out quickly (5 seconds in water max), and threw it in a bag of rice for a day, in sunlight. It wouldn't turn on for a few days. After those few days, I put it on the charger and it came on, however the screen was messed up (Parts white, parts black, not showing anything in particular). I plugged it into the computer and it recognized it as in recovery mode. I have since replaced the LCD and digitizer myself, and restored and updated to 4.3.5. However, the screen is now solid white (new LCD). It sounds like it boots up successfully and connects and syncs with iTunes, but I don't think it receives my input. The lock and home buttons function fine. Any idea what the problem is?
     
  2. kbfr08 macrumors 6502

    kbfr08

    Joined:
    Mar 16, 2007
    #2
    You need to take the ipod apart again, remove the logic board, and clean it with isopropyl alcohol (90% or more) and a toothbrush. Remove the EMI shield / speaker from the bottom of the board to expose the cpu. Also peel the QR code sticker on the lower right corner of the underside of the board. Scrub the ipod with a toothbrush, dry, look for remaining residue, and repeat or reassemble

    Once your done scrubbing the board clean, dry it using a blow dryer on the hot setting until the board looks dry.
     
  3. PercussiveScruf thread starter macrumors newbie

    Joined:
    Sep 20, 2011
    #3
    Awesome, school has had me bogged down, but I'll have some free time tomorrow so I'll try it then! Thanks for the response, I'll post again with results! =D
     
  4. PercussiveScruf thread starter macrumors newbie

    Joined:
    Sep 20, 2011
    #4
    Sorry for the late response, that didn't seem to do it. Could it be that the logic board is just gone? Everything still happens the same, the screen lights up and iOS is running, but I can't see anything and I can't use the touch screen.
     
  5. just-being-me macrumors newbie

    Joined:
    Sep 26, 2011
    #5
    hmm.. im not sure if this will solve it but is your screen completely white blank? im not as technological as the other person but try press the menu button the same time as the off/on button. not sure if its the same situation as my ipod befor but you might as well give it a try (if you havent already)
    hope i was of help! :D
     
  6. PercussiveScruf thread starter macrumors newbie

    Joined:
    Sep 20, 2011
    #6
    Nah, that didn't work, but I had already tried that. I really do appreciate the input, though! =D
    I figure I may try again later but I think for now it'll just gather dust for a while. I may pick up a 5th gen next month haha
     

Share This Page