White screen start-up/ Disk stuck

Discussion in 'iMac' started by menji, Apr 26, 2013.

  1. menji macrumors newbie

    Joined:
    Apr 26, 2013
    #1
    Mac OS 10.4 iMac desktop.

    Recently got a new printer and was using the install disk to install the drivers. I put the disk in and I just had a loading mouse icon for several minutes. Couldn’t click anything, couldn’t eject and the printer icon did not show up. Shut down the computer and when I turned it back on I get the white screen.

    I’ve tried many things to eject the disk:
    - Held the mouse down during start-up.
    - Held eject during start-up.
    - Unplugged the power and used the two credit card trick. There seems to be some lock in the middle of the cd slot as I can’t seem to find the CD.

    As for trying to get to the login screen:
    - Restarted holding command+shift+p+r and was able to get it to restart again but nothing happened after that.
    - Restarted trying to get to safe mode by holding shift.
    - Unplugged the usb keyboard and power, waited a minute, plugged back in and nothing when I turned it on.
    - Switched to many different outlets, no results.
    - Unplugging everything, holding the power button for 10 seconds and then plugging everything back in.
    - Unplugging everything, waiting, plug everything back in and at the same time hold power button until loud beep noise came from computer.

    None of those solutions have worked.

    Sometimes my iMac will turn on by itself after plugging the power cords back in and without me hitting the power button.

    Just about every solution I could find online has been tried to no avail. I feel like the CD is causing the problem and if I can just get that out it will start up fine because it’s been working fine for some time.

    Any suggestions?
     
  2. bhaveshp macrumors newbie

    Joined:
    Jun 9, 2010
    #2
    What model iMac?

    Considering 10.4, I'm guessing iMac G4 or iMac G5?

    I had an iMac G4 that would get stuck on a white screen upon power up. It turned out to be a Hard disk that was dying. After replacing the drive, it still works fine.

    Any chance you can boot with an external drive?
     
  3. macthefork, Apr 26, 2013
    Last edited: Apr 26, 2013

    macthefork macrumors 6502

    Joined:
    Feb 2, 2013
    #3
    Yes, sounds older to be using Tiger OS.

    You can try starting in Single User Mode. Shut down the iMac. Press the power button to start the computer. Immediately press and hold the Command (Apple) key and the "s" key.

    Once you see all the text complete, try typing /usr/bin/drutil eject

    To restart the iMac after you're finished, type "reboot" (without the quotes) and then hit enter

    You could also try booting into Open Firmware by holding down Command, Option, O key and F key during startup. After booting into Open Firmware, type the command eject-cd or try the command /usr/bin/drutil eject

    Some have simply typed "drutil eject" (without the quotes) in Open Firmware and had the stuck disk ejected, too.
     
  4. menji thread starter macrumors newbie

    Joined:
    Apr 26, 2013
    #4
    G5

    And I was worried it might be a hard drive issue but I still feel like it has to be a problem with the disk at the moment. I've never tried to boot from another drive, how would I go about doing that? I do have an external hd I've been using as a back-up.
     

Share This Page