White screen with Portal

Discussion in 'Mac and PC Games' started by heynsmd2, May 13, 2010.

  1. heynsmd2 macrumors newbie

    heynsmd2

    Joined:
    May 1, 2005
    Location:
    Durham, NC
    #1
    Just downloaded Steam and Portal. I'm only getting white (blank) screen in Portal. I've googled problem and it seems some Windows users had same problem on launch.

    Any ideas to fix portal for Mac?

    IMac 2.16/x1600
     
  2. susannahyork macrumors member

    Joined:
    Aug 30, 2005
    #2
    I have the same problem and would greatly appreciate any help.

    2.33 x1600 mbp
     
  3. rein020b macrumors newbie

    Joined:
    Jan 15, 2004
    Location:
    St. Louis
    #3
    White screen in Portal

    Same here! Mac Pro, 2 x 2.66 GHz, ATI X1900. The same hardware plays Portal with no problems under Windows.
     
  4. heynsmd2 thread starter macrumors newbie

    heynsmd2

    Joined:
    May 1, 2005
    Location:
    Durham, NC
    #4
    Leopard OS X

    I'm still running Leopard (10.5.8) on the iMac with the 'white screen' problem. Could this be a factor?
     
  5. bhallstein macrumors newbie

    Joined:
    May 13, 2010
    #5
    Same

    Same here: MBP 2.16 Core Duo, ATI x1600.

    Looks like perhaps an issue specific to that generation of GPUs?
     
  6. rbarris macrumors 6502

    Joined:
    Oct 28, 2003
    Location:
    Irvine CA
    #6
  7. azankorejo macrumors newbie

    Joined:
    Jun 28, 2017
    #7
    --- Post Merged, Jun 28, 2017 ---
    SEE THIS VIDEO:
     
  8. jeanlain macrumors 65816

    Joined:
    Mar 14, 2009
    #8
    Maybe these posters no longer needed a solution after 7 years. :rolleyes:
     

Share This Page