White space around Flash on html page

Discussion in 'Web Design and Development' started by djsound, Feb 5, 2010.

  1. djsound macrumors 6502a

    djsound

    Joined:
    Dec 4, 2006
    #1
    Good evening all! First off yes I'm a newb. I am trying to make a simple website..I made a flash menu and inserted it into my html page and it has a white 'area' above & below the menu that should NOT be there....it doesn't exist in Dreamweaver...I made the table exactly the same size as the flash menu.... Can anyone help? thanks

    http://www.vitalityfitnessandtraining.com/
     
  2. Ride9650 macrumors 6502

    Joined:
    Jun 29, 2007
    #2
    What size is the stage in your flash file?

    is it the same size as your menu? If it isn't that's whats causing the white space.
     
  3. djsound thread starter macrumors 6502a

    djsound

    Joined:
    Dec 4, 2006
    #4
    Ya, I dont know.. :(

    688x66..same size as the table. hmmm
     
  4. Ride9650 macrumors 6502

    Joined:
    Jun 29, 2007
    #5
    I think I found the issue, you set the height of the table to be 160px, not 62px like the movie.

    Code:
      <td height="222" colspan="2" valign="top" bgcolor="#CCCCCC"><img src="images/test_header_1.jpg" width="688" height="[B]160[/B]" /><br /> 
          <object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,19,0" width="688" height="62"> 
            <param name="movie" value="flash/vitalityflashmenu.swf" /> 
            <param name="quality" value="high" /> 
            <embed src="flash/vitalityflashmenu.swf" quality="high" pluginspage="http://www.macromedia.com/go/getflashplayer" type="application/x-shockwave-flash" width="688" height="62"></embed> 
        </object></td> 
      </tr> 
    
     
  5. UTclassof89 macrumors 6502

    UTclassof89

    Joined:
    Jun 10, 2008
    #6
  6. digitalField macrumors regular

    Joined:
    May 21, 2004
    Location:
    portland
    #7
    Hey hi hello..

    make sure you have some css in your html that zero outs the padding and margins for your html and body tags.. browsers, by default, have certain settings for various tags...

    should look something like this..


    Code:
    <style>
    html,body{padding:0;margin:0;}
    </style>
    
    that should get rid of the white space.

    M!

    just noticed you have this in a table cell.. so put this in there too..
    Code:
    <style>
    td{padding:0;margin:0;}
    </style>
    
     

Share This Page