Who has fixed the home share dropping issue?

Discussion in 'Apple TV and Home Theater' started by rlu929s, Oct 4, 2011.

  1. rlu929s macrumors regular

    Joined:
    May 17, 2011
    #1
    I'm still battling this. I have no choice, but to use wifi in my house.

    My setup:
    1. ATV2
    2. Airport Extreme 2011

    If I reboot my router it will work at that time, but after sitting for awhile it loses the home share again. So far the main way to reset is rebooting my router.

    What I've tried:

    1. I have software firewall on my Itunes Server, so I have full exempted Itunes and opening those suggested ports.
    2. I've set my DHCP Lease time on the Airport to 365 Days.
    3. I've went into Port Forwarding and setup the allowed ports (I Think) I'm a little fuzzy on this one. I put a rule for the ports and set the private IP to 10.x.x.2-200
    4. I've set my ATV2 to never sleep.

    What am I missing? I just want this thing to work. It's mainly used for the kids to watch cartoons in the morning and it's a pain to go downstairs (where router is) and mess with rebooting it and closing itunes every morning.

    I know the connection is fine as I can browse YouTube just fine at all times.
     
  2. Macman45 macrumors demi-god

    Macman45

    Joined:
    Jul 29, 2011
    Location:
    Somewhere Back In The Long Ago
    #2
    Unless You Have A faulty Router

    You've done it all correctly....Just one thing..Set the lease time to never drop the connection....Sometimes the time zone can interfere with those settings.
     
  3. Buff401 macrumors newbie

    Joined:
    Aug 8, 2010
    Location:
    SW England
    #3
    I know the feeling - try this

    I have been struggling to get a stable wireless connection to my ATV2 for months. The connection kept dropping and required frequent re-configs which was embarrassing when showing photo slideshows etc. Then I realised that I was already using Devolo plugs to link my iMac/Router in one room to my Speakers 2 rooms away (through several thick walls) and music streamed without a problem. So I bought another Devolo plug, linked my ATV2 with a short Ethernet cable supplied and - Bingo! perfect streaming of all my photos, plus my music, plus my MobileMe stuff etc. Haven't tried Movies yet but don't anticipate a problem. It does, of course mean extra financial outlay but its worth it to escape the uncertainty of wireless connection. (I entered this in another post a few days ago but it might be relevant to you)
    __________________
     
  4. rlu929s thread starter macrumors regular

    Joined:
    May 17, 2011
    #4
    I didn't see in the airport where there was a never drop connection setting?

    Here's my port mappings. Couldn't get the UDP to enter.

    [​IMG]
     
  5. rlu929s thread starter macrumors regular

    Joined:
    May 17, 2011
    #5
    Well looks like we do have an IOS5 update incoming. Here's hoping this fixes a lot of our issues.

    I read somewhere that someone with a beta of IOS5 reported it fixed the home share dropping.
     
  6. Wavell macrumors regular

    Wavell

    Joined:
    Nov 7, 2007
    Location:
    Essex, UK
    #6

    I feel your pain.. I have a TC at home that I use to generate my Wi-Fi signal, and my ATV2 downstairs that I used to stream to. Like you, using ethernet wasn't an option (I'm cr@p with cabling things anyway)..

    however.. I bought an Airport Express (I needed to extend my Wi-Fi anyway), plugged that in near my ATV and then cabled my ATV to the Ethernet port on the Airport Express..

    Not had a single home-sharing drop-out since. There's something *definately* wrong with ATV2 and it's Wi-Fi.

    Might be worth a shot for you :)
     
  7. mstrze macrumors 68000

    Joined:
    Nov 6, 2009
    #7
    Not a true fix, but a suggestion:

    Instead of taking the time to reset the router, I have found the quickest way to restore Home Sharing is to just go into the ATV2 menu and stop and then restart home sharing. It takes seconds and it works everytime for me.
     
  8. cdavis11 macrumors 6502

    Joined:
    Aug 31, 2009
    #8
    I've had very good luck with switching to one of the built in screen savers, not using my photo library.

    I've also unchecked "keep iTunes folder organized" in Itunes settings.

    These two things have made a huge difference.

    I went through hell with this problem for a long, long time. I searched high and low and found references to those two small changes and it fixed 99% of my issue.

    I still get "Loading Library..." for 3-5 seconds at times when browsing my shared library of movies, but nothing like the lockup/timeouts I would experience before.
     
  9. Buff401 macrumors newbie

    Joined:
    Aug 8, 2010
    Location:
    SW England
    #9
    Different solution same success

    Yep, you say AE, I say Devolo, Lets say we both cracked it - no matter, it was doing my head in
     
  10. whooleytoo macrumors 603

    whooleytoo

    Joined:
    Aug 2, 2002
    Location:
    Cork, Ireland.
    #10
    It was quite bad for me (would drop at least a couple of times a day). In the end I connected the ATV via Ethernet and it's worked flawlessly since; a few weeks without a single disconnection.

    Obviously, that's not much of a consolation for anyone who needs to use Wifi. When I was using Wifi, I did find the following helped a bit:
    - Manual TCP/IP setup, not DHCP
    - Only have 1 Wifi router in range, if possible. I had two, and that setup never worked well.
    - If you're picking up a neighbour's wifi network(s), ensure you don't have a clash of channels.
    - Use a reliable DNS server.
     
  11. gavdav macrumors newbie

    Joined:
    Aug 29, 2011
    #11
    Streaming freeze

    Hi all, maybe a similar issue but on my atv2 in the bedroom (wireless connection) I can connect to my computer library, see all films with the images, select a film, choose resume play or start from the beginning but then that's it - if I select resume it will have a frozen picture of where it last played from and the spinning wheel will spin and spin and spin, so won't play

    Same with start from beginning as well

    YouTube works sometimes but long stream, photos are OK

    the annoying thing is it used to work. Since the new wireless router I am having these issues and am sure it must be some sort of setting issue

    Any thoughts??

    Cheers
     
  12. craig4568 macrumors member

    Joined:
    Jun 25, 2010
    Location:
    North Yorkshire
    #12
    Wire it

    I tried everything with atv2 the only thing that sorted it was ethernt wiring hasn't dropped since I'm a bit pissed off with apple at present .the trouble I'm having with airpot express is so frustrating it's unbelievable
     
  13. slothrob, Oct 9, 2011
    Last edited: Oct 9, 2011

    slothrob macrumors 6502

    Joined:
    Jun 12, 2007
    #13
    Is this just a problem with the Airport Extreme?

    I've never had these problems with my cable router's wifi.
     
  14. gavdav macrumors newbie

    Joined:
    Aug 29, 2011
    #14
    Thanks for the feedback guys. No Airport extreme, NetGear N150 router which is just playing up all the time.

    cheers - wish i had run cable round the house when we renovated!!!!
     
  15. UneElle macrumors member

    Joined:
    Jun 14, 2010
    #15
    Mine hasn't worked for quite awhile. I tried everything to get Home Sharing to function again without success. Frankly, I just gave up. But tonight, for some reason, I turned ATV2 back on, and as inexplicably as it had quit working, without my doing anything else at all, there it was...functioning perfectly once more. Gremlins? Who knows? :confused:
     
  16. rlu929s thread starter macrumors regular

    Joined:
    May 17, 2011
    #16
    So, IOS5 is now out. Has anyone updated to it and seen this issue fixed?

    I will update when I get home and cross my fingers. Would rather not buy anymore devices like an AE or Devlo!
     
  17. somemacuser macrumors newbie

    Joined:
    Oct 25, 2010
    #17
    Looking good so far

    I did the updates yesterday and as of today, no drops. Not ready to fully declare victory for a few more days, but I can tell you I would have at least one drop by now. Keeping fingers crossed.. Looking good so far.
     
  18. nkawal macrumors regular

    Joined:
    Jan 12, 2011
    Location:
    NYC
    #18
    I have 2 ATV2's and was always up to date on software releases, Never had the issues. I updated last night and boom, both of them are now dropping the home sharing connection. WTF
     
  19. somemacuser macrumors newbie

    Joined:
    Oct 25, 2010
    #19
    OK, I'm now two days in and no drops.. Still not calling it 100% fixed yet, but its definitely changed for the better.
     
  20. rlu929s thread starter macrumors regular

    Joined:
    May 17, 2011
    #20
    Well....no luck:( Got another drop last night, post IOS5.

    I've noticed that since updating my ATV acts more sluggish on loading the cover art pictures etc.

    It's odd because I can turn around and play an HD trailer no problem.

    I guess the only thing left to try is to get a Airport Express or Devolo and wire it. I've heard this works.
     
  21. PaulMoore macrumors regular

    Joined:
    Dec 3, 2007
    #21
    When I set my Apple TV to never sleep the problem went away.
     
  22. rlu929s thread starter macrumors regular

    Joined:
    May 17, 2011
    #22
    I've tried everything besides what I've posted above. I'm afraid the ATV2 will not might me needs the way it is. After all the time I spent ripping movies I may end up putting these on eBay.
     
  23. whooleytoo macrumors 603

    whooleytoo

    Joined:
    Aug 2, 2002
    Location:
    Cork, Ireland.
    #23
    My iPad/ATV setup has been flawless for weeks since I switched to Ethernet and manual network settings.

    ...and then I upgrade to iOS 5 and have two disconnects in a day. Both times, I was playing music for a while, and when I tried to pause it via the Remote the song just kept playing. When I went out to the device select screen in Remote, the ATV was gone (but the music was still playing).

    I had to reset the device, and fingers crossed it doesn't happen again.
     

Share This Page