Who has hacked iphone then (UK)

Discussion in 'Jailbreaks and iOS Hacks' started by mattpreston11, Nov 17, 2007.

  1. mattpreston11 macrumors 6502a

    Joined:
    Nov 9, 2007
    #1
    whos used the method on hackingt0sh then? and more importantly, any windows users tried it?

    getting my iphone on tuesday, but as an xp user i want to know i can do it.

    thanks.
     
  2. quixers macrumors member

    Joined:
    Nov 12, 2007
    #2
    Yes I have -
    Findings from jailbreaking a UK o2 activated 1.1.2 iphone, cheers to wrboyce for the support!

    My setup: Windows XP, ITunes 7.5

    What I used:
    ibrickr
    http://cre.ations.net/creation/ibrickr

    conceited jailbreak package
    http://conceitedsoftware.com/iphone/site/112jb.html

    o2 edge/visual voicemail fix from here:
    http://code.google.com/p/iphone-elit.../o2ukJailbreak

    1.1.1 and 1.1.2 iphone firmware restore files (google for them)

    1. In itunes connected phone and held shift & clicked restore - selected 1.1.1 firmware file. Flashed and finished with error 1015. Phone displayed connect to itunes picture.
    2. Got the phone to boot into 1.1.1 with ibrickr using this method:
    * Run iphoneinterface in a Command Prompt window.
    * You should see an "r_recovery" prompt.
    * Enter "setenv auto-boot true", "saveenv", and "fsboot" (each on their one line).
    * Wait for iPhone to reboot -- may take a minute.
    3. My SIM was locked and couldn't activate - removed SIM and PIN unlocked it in another phone. Popped it back in.
    4. Activated phone in itunes. Phone is now on home screen in 1.1.1 Note: No GSM connection at this stage.
    5. Visited jailbreakme.com in safari and attempted to install Installer.app. Didn't work the first time so I had to switch phone off and back on again and retry. Worked this time. Should display progress when its working, before I rebooted it just quit back to home and nothing happened.
    6. Installer now on home screen. Installed OktoPrep (in tweaks)
    7. Ran ITunes shift-clicked *UPDATE* and choose 1.1.2 firmware. Waited. Itunes activates phone.
    8. Running conceited jailbreak - windows.bat. Flashing firmware and installing ssh. Takes a while!
    9. Hrmm looks like it didn't work on home screen and no installer. Turning phone off and on. It worked! Now in 1.1.2 and jailbroken VV and EDGE are broken however.
    10. Used putty to ssh into iphone. Ran the following to get o2 edge and visual voicemail working:
    rm /var/root/Library/Preferences/com.apple.carrier.plist

    cp /System/Library/Frameworks/CoreTelephony.framework/Support/O2_UK.plist /var/root/Library/Preferences/com.apple.carrier.plist

    rm -f /var/root/Library/Preferences/SystemConfiguration/preferences.plist

    ******************

    Phone is fully functional in 1.1.2 with visual voicemail confirmed working and GPRS certainly works (no EDGE where I live - damn o2!).

    Hope this helps someone out here or gives them the guts to try it too
     
  3. koobcamuk macrumors 68040

    koobcamuk

    Joined:
    Oct 23, 2006
  4. tonywob, Nov 19, 2007
    Last edited: Nov 6, 2011
  5. metoo6000 macrumors regular

    Joined:
    Sep 18, 2007
    Location:
    London, UK
    #5
    Is this only for O2 contract and simplicity? Will it works with payg sim?
     
  6. quixers macrumors member

    Joined:
    Nov 12, 2007
    #6
    metoo6000: will prob fix edge settings for those types of SIMs, but doubt visual voicemail will work. Worth a try.. I have a proper iphone o2 sim in mine
     

Share This Page