Who is calling???

Discussion in 'iPhone Tips, Help and Troubleshooting' started by JoMiSan, Nov 26, 2007.

  1. JoMiSan macrumors newbie

    JoMiSan

    Joined:
    Nov 26, 2007
    Location:
    Spain
    #1
    I am now in Spain and I have all my contacts with international digits (+34 91 123456) and here is the problem; when people call my from within Spain (there is no +34) iPhone is just showing the calling number, but cannot identify it as one of my contacts.

    Anyone knows if this bug is solved in 1.1.2?
     
  2. koobcamuk macrumors 68040

    koobcamuk

    Joined:
    Oct 23, 2006
    #2
    I have changed contacts to have both numbers. one with +44 and one with 0.
     
  3. skeen macrumors 6502

    Joined:
    Jul 12, 2007
    Location:
    London, England
    #3
    What an awful, tedious solution. You're saying every single one of your contacts has 2 of the same number? Wow.

    Mine works just fine.
     
  4. JoMiSan thread starter macrumors newbie

    JoMiSan

    Joined:
    Nov 26, 2007
    Location:
    Spain
    #4
    Works fine with +44 numbers???.
     
  5. rayward macrumors 65816

    Joined:
    Mar 13, 2007
    Location:
    Houston, TX
    #5
    I'm guessing you're roaming the whole time when in Spain, as there's no domestic service there yet. Not sure if this makes a difference to how the iPhone behaves.

    You might want to try putting all your local numbers in as local numbers (or at least experiment with a couple of them) and see if they caller id feature works. The iPhone has an international calling assist feature that will automatically add the necessary international prefix when dialing local numbers from foreign locales (it's under Settings/Phone). This works perfectly for me and might fix your caller id problem.
     
  6. JoMiSan thread starter macrumors newbie

    JoMiSan

    Joined:
    Nov 26, 2007
    Location:
    Spain
    #6
    Where is that? I can not find that assist feature on 1.1.1.
     
  7. rayward macrumors 65816

    Joined:
    Mar 13, 2007
    Location:
    Houston, TX
    #7
    It's right there at the top of the page under the phone settings. It's an On/Off button labeled "International Assist". It was there from the very beginning on my U.S. phone. Maybe it's not available for European phones.
     
  8. JoMiSan thread starter macrumors newbie

    JoMiSan

    Joined:
    Nov 26, 2007
    Location:
    Spain
    #8
    Right, not in European ones.
     
  9. rayward macrumors 65816

    Joined:
    Mar 13, 2007
    Location:
    Houston, TX
    #9
    Weird.
     
  10. JoMiSan thread starter macrumors newbie

    JoMiSan

    Joined:
    Nov 26, 2007
    Location:
    Spain
    #10
    I think they should change the way to match phone numbers. It is working ok in Nokia, Motorola, Sony... All the others, just check the numbers (without the country code), and that's all!!. I do not know why Apple check also the country code.
     

Share This Page