WHOIS command not working

Discussion in 'Mac Basics and Help' started by someguy, Apr 4, 2012.

  1. someguy macrumors 68020

    someguy

    Joined:
    Dec 4, 2005
    Location:
    Still here.
    #1
    I've got an Intel i3 iMac and just did a fresh reload of Snow Leopard this week. The first time I went to use the WHOIS command, it did not work. It only seems to hang, never spitting out any information about the domain I give it.

    Code:
    $ whois google.com
    
    Whois Server Version 2.0
    
    Domain names in the .com and .net domains can now be registered
    with many different competing registrars. Go to http://www.internic.net
    for detailed information.
    
    This works fine on other systems on the network, and I don't have any software installed on this Mac that I think would cause this. Here are a couple of things I've tried:

    • Set the Mac to use DHCP, because the other systems I've tried are in the DHCP IP pool.
    • Set the other working machines to source-nat using the same public IP that I use for this Mac, and they continued to work even after clearing local DNS caches.
    • Disabled IPv6 (I do use this normally, and have never had any issues).

    This machine replaced a MacBook Pro which never have me any issues. It used the same private and public IP addresses, and nothing has changed in the router firewalls.

    I use this command all the time, and I don't want to have to keep using SSH or the web to do a WHOIS lookup. Please help!
     
  2. chown33 macrumors 604

    Joined:
    Aug 9, 2009
    #2
    Which whois server are you using?

    If it's the default (see 'man whois'), what happens if you use a different whois server?


    What happens if you use Network Utility.app, located in /Applications/Utilities, which has a Whois tab?

    Do any of the other utilities in Network Utility.app fail, like Ping or Lookup?
     
  3. someguy thread starter macrumors 68020

    someguy

    Joined:
    Dec 4, 2005
    Location:
    Still here.
    #3
    Turns out it was because IPv6 was enabled, even though, as I mentioned, I did disable it at one point during the troubleshooting process. Not sure what happened there.

    Now what confuses me is that my MacBook never had this issue and was using 10.6.8 and IPv6. I don't recall ever doing anything differently that would affect how whois behaves.. :confused:
     
  4. jameshsi macrumors newbie

    jameshsi

    Joined:
    Sep 21, 2009
    #4
    I got this issue too, I search and found this thread, and I solve my problem by:
    select the wifi I am using (I use Airport express), and click advance, then click the tab TCPIP, on the IPv6 part, I select only local connect, and apply, the problem solved, now I can use whois command with no problem.
     

Share This Page