Whole partition just dissapears - OS X doesn't boot

Discussion in 'MacBook Pro' started by ajthomason, May 4, 2008.

  1. ajthomason macrumors 6502

    #1
    Ok, this is an interesting problem.

    So, I was using my MPB (Nov 2007) and CyberDuck kept freezing, so I decided to restart. On restart, mail refused to quit so I had to forcequit it. The rest of the shutdown was fine.

    Then it tried to start up again. The apple logo appeared along with the spinning cog thing underneath it. This screen stayed and never went, so I held down the power button and tried again - the same.

    I then loaded the 10.5 upgrade disk and when it had loaded, it did the usual "Checking for previous versions of OS X". It then came back with the error saying that OS X 10.4 or later was not installed on my MPB (This is the point that I actually got worried). I went into disk utility and it listed the HD but there was no partition.

    I then went to terminal and entered 'Volumes', the only one listed was the install DVD. I restarted and tried again; the same. I waited a while and tried again just for the sake of it and the Macintosh HD actually appeared in terminal.

    I have not tried booting again or going back to Disk Utility because at the moment I am using terminal to copy all files that I have changed since making my last backup (on the 27th of April) to my external drive - at the moment it is copying my 30GB aperture library so it may take a long time.

    Does anyone have any ideas why the whole partition would just dissapear and yet when booting OS X, it didn't say an equivilent to the windows "Operating sytem not found" error? And why, stranger still, it would just appear again in terminal. I guess I had better wait until I have copied all files and try booting again. At least with Time Machine, I will have most of my files.

    I have not dropped my laptop or given it any other shocks, it has been working fine all day until just before I restarted it.

    AJT.
     
  2. ajthomason thread starter macrumors 6502

    #2
    UPDATE: After I finished copying files, I went back to the Disk Utility and the partition magically appeared. I verified it and there was no problem.

    I restarted the mac and it loaded as if nothing was wrong.

    Although I'm glad I have my mac back, I am still worried that the partition could just dissapear like that.

    Anyone had any ideas - A dodgy SATA controller?

    AJT.
     
  3. IJ Reilly macrumors P6

    IJ Reilly

    Joined:
    Jul 16, 2002
    Location:
    Palookaville
    #3
    I'd suspect some sort of directory issue on the hard drive. Now is the time to run Disk Utility (or fsck if you know how) to find and repair any errors it detects.
     
  4. e12a macrumors 68000

    e12a

    Joined:
    Oct 28, 2006
    #4
    ditto, i'd look into the HD more before concluding its a logic board issue.
     

Share This Page