Whole workgroup (SMB) dies for Macs but not PCs

Discussion in 'Mac OS X Server, Xserve, and Networking' started by jettoblack, Mar 5, 2010.

  1. jettoblack macrumors member

    Nov 1, 2006
    Hello all,
    I'm having a very frustrating problem with a mixed Mac (Snow Leopard) and PC (Vista/XP) home network. Normally everything works fine and I can share files and printers between the Macs and PCs (i.e. this is not a simple configuration or permissions issue).

    However, when I try to do a large (~500MB or so) file transfer from any Mac to any PC (wired or wireless, doesn't matter), the WHOLE workgroup dies for all Macs on the network. When I say the whole workgroup, I mean all the Macs lose access to any machine in the SMB workgroup (i.e. WORKGROUP or whatever all the machines are set to). Specifically, this is what happens:

    - All SMB shares immediately stop working on all Macs (transfers in progress are cut off)
    - All Macs and all PCs can still access the internet just fine and can still ping each other, so it isn't like the network connections have physically died or the router froze, etc.
    - Using Finder Go > Connect to server, none of the Macs can access any SMB share on the network, either by name (smb://pc-name) or by IP address (smb:// Doing so results in an immediate "Connection failed" message (i.e. it doesn't time out or stall, it just fails instantly)
    - Windows machines can continue to access all SMB shares (including Mac shares) just fine! Just not vice versa.

    Here are some things I've tried so far:

    - Rebooting any/all Macs does NOT clear up the issue. It's as if the whole SMB workgroup is stuck in a "corrupt" state which is not cleared by rebooting the Macs.
    - Switching from wired to wireless or vice versa doesn't help.
    - Turning ALL machines off, waiting a while, then turning all back on again clears the problem, but only until the next large file transfer.
    - Changing the workgroup name on all machines temporarily solves it until the next large file transfer (but this requires rebooting all the PCs which is a huge hassle).
    - Tried clean reinstalling Snow Leopard on several of the Macs -- no change.
    - Clean reinstalled Vista on several of the PCs -- no change.
    - Changed the internet/WiFi router for a different brand (now using DD-WRT) -- no change.
    - Changed the Ethernet switches to different brands and used new Ethernet cables to each wired machine -- no change.

    I'm not a networking guru but I'm a software developer and have been running a mixed Windows/Linux/Mac home network for some time now, so I'm not a novice either. This is one of the more frustrating problems I've ever faced.

    If anyone has ANY ideas, it would be greatly appreciated.

  2. theinstructor macrumors regular


    Jul 13, 2007
    A couple of things you may want to try if you have not already:

    - Ensure patches are all up to date
    - Maybe find out if your MTU network configuration match up on the network cards/OSes/Network Devices (MTU mismatches can cause re-transmission of packets that can also cause a connection to fail) although on home networks it usually isnt a problem

    Seems like this type of situation would have been encountered before and maybe something available on Google...let us know if you come across a solution. :apple:
  3. setasai macrumors member

    Apr 25, 2005
    I have this same exact issue and I've tried all the same things you have with the same results. This only started since Vista and Win7. With WinXP i've never had this problem before. I'll report back if I find a solution but this has been happening alot and I've resorted to using FTP on the windows computer for file transfers. Not ideal, I know, but I havent found a solution yet.

  4. dyn macrumors 68030

    Aug 8, 2009
    With dd-wrt you can limit the bandwidth for smb for specific machines. You could try to limit the Windows machines to see if the Macs stay connected to the networkshares (the speed may drop but that's allright if the filetransfer keeps going). If in this case things keep on working you may have some issues regarding bandwidth. Windows Vista and 7 brought along some changes to networking as Microsoft completely rewrote it. This could be the cause to your problems (XP uses the networking stuff that was based of off the BSD networking stack).
  5. kochen macrumors newbie

    Jun 5, 2010
    Try disabling IPv6 on all vista/win7 clients. It often seems to cause problems!
  6. Tim018 macrumors regular

    May 31, 2009
    I also have this exact issue on my macbook while connecting to a win7 machine. I have found the easiest solution is to use only wifi and no hard wire connection. It seems that the hard wire essentially overloads the router(network?) and kicks me off until the win7 machine is restarted. The wifi is a fair amount slower than the hard wire so it limits how fast stuff can be transferred. for now it works but id like to find a better solution.

    For the OP obviously this solution didn't work as he posted that it glitched both with the hard wire and the wifi. Does anyone know a way to throttle/slow the speed that files can be transferred to/from a server on the mac? Id rather not fiddle with the router itself as you said dyn because it operates our entire company so there really is no room for down time if it gets messed up.

    @kochen: i tried that, but it didnt appear to have any effect, transferring a large file still kicked me off.

    if anyone has ideas I'm willing to try them, i've been stuck using bootcamp the last few days till i figured this half solution so im very willing to try any ideas...



Share This Page