Whoops... Resized Mac Partition, can't boot Win7

Discussion in 'Windows, Linux & Others on the Mac' started by portcontrol7, Mar 4, 2012.

  1. portcontrol7 macrumors member

    Joined:
    Aug 28, 2011
    #1
    Yeah. So I put the Windows 7 CD in to try to repair the partition, but it cannot recognize a Windows installation. I have refit installed as well, and still cannot boot windows. Any ideas would be greatly appreciated. Of course the data is still there on the Bootcamp partition, I just cannot boot.

    Thanks.
     
  2. portcontrol7 thread starter macrumors member

    Joined:
    Aug 28, 2011
    #2
    Seriously?

    This is new? Never happened to anyone? Damn, I must be innovative!
     
  3. wpotere Guest

    Joined:
    Oct 7, 2010
  4. FallibleCanine macrumors newbie

    Joined:
    Mar 16, 2012
    #4
    I had this same problem.

    I wanted some more space for music that I could listen to from my Windows 7 system. So I shrunk my Mac partition and created a new "MEDIA" partition, with the intent of formatting it from Windows or something.

    On restarting, I found I couldn't boot into Windows. (It didn't appear when I held down the Alt key. When I tried using System Preferences --> Startup Disk to boot into it, I was able to select the Win7 system, but on startup it gave me a black screen reading "No bootable disk". I deleted the MEDIA partition. No luck.

    The Windows 7 partition is clearly intact. I can view it from OS X, copy files from it, and so on. It's right there in Disk Utility.

    I'd really rather not reinstall everything and fiddle with all the settings all over again.

    My guess: the ... boot sector? ... or whatever got messed up. Can I rebuild that somehow? Windows 7 is clearly still there.
     
  5. FallibleCanine macrumors newbie

    Joined:
    Mar 16, 2012
    #5
    Here's an image to illustrate the situation.
     

    Attached Files:

  6. FallibleCanine macrumors newbie

    Joined:
    Mar 16, 2012
    #6
    Hooray! FIXED!

    I fixed it!

    Download and install this program:

    http://refit.sourceforge.net/

    Then open up a Terminal window (Utilities --> Terminal) and enter this command:

    sudo /efi/refit/enable-always.sh

    Then you can just restart and it'll let you select the Windows partition.


    Apparently, the problem is that with Boot Camp you maintain two "boot records"; the default Apple one isn't smart enough to figure out what to do when you've resized a partition, but refit is.
     

Share This Page