Why a game only works under Lion?

Discussion in 'macOS' started by hajime, Dec 22, 2011.

  1. hajime macrumors 68040

    Joined:
    Jul 23, 2007
    #1
    Hello. I was trying to download a free game from the Apps Store. I was not allowed to do so as I am running Snow Leopard. I had a look at the requirements and found that the program is compatible with only Lion. Anybody knows the reason?
     
  2. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #2
    The software is using APIs or libraries only found in Lion
     
  3. hajime thread starter macrumors 68040

    Joined:
    Jul 23, 2007
    #3
    Thanks. I am considering whether or not to upgrade to Lion. Do you expect that there will be more and more applications that will use APIs or libraries only found in Lion? (I love Space of Snow Leopard.)
     
  4. adder7712 macrumors 68000

    adder7712

    Joined:
    Mar 9, 2009
    Location:
    Canada
    #4
    Could have something to do with OpenGL?
     
  5. hajime thread starter macrumors 68040

    Joined:
    Jul 23, 2007
    #5
    That game is called "Tires of Fury".

    "Let's Golf! 3" requires 10.7 or later as well :(
     
  6. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #6
    You're going to see this more and more. Lion is the current OS. Developers do not want to deal with supporting legacy OS's if they can avoid it.
     
  7. hajime thread starter macrumors 68040

    Joined:
    Jul 23, 2007
    #7
    Is it going to be mainly on games related apps?
     

Share This Page