Why am I sending viruses from OSX?

Discussion in 'Mac Apps and Mac App Store' started by The Red Menace, Nov 27, 2005.

  1. The Red Menace macrumors member

    Sep 27, 2005
    Here's the deal. A few weeks ago I started to get macro warnings every time I opened a Word 2004 document. I changed the prefs, so it would not ask anymore. Now every time I attach a document and send it with yahoo mail, it says a virus was found and cleaned in the doc. What is causing this? Is this something I should worry about? :confused:
  2. Sun Baked macrumors G5

    Sun Baked

    May 19, 2002
    Your "normal" document that you use to create all those documents you are sending can be infected.
  3. The Red Menace thread starter macrumors member

    Sep 27, 2005
    what does one do to correct the problem?
  4. andcraig macrumors regular

    May 28, 2005
    under "Your name"/documents there's a folder called "Microsoft User Data" or some such thing

    Trash it.

    Then whenever you open a file be sure to disable macros. Copy the text of every doc you've opened since you got the macro virus and put it into a new word doc that isn't infected.

    its a pain, but so are macro viruses.
  5. emaja macrumors 68000

    May 3, 2005
    Chicago, IL
    Download and run ClamAV
  6. Flying Llama macrumors 6502a

    Flying Llama

    Aug 4, 2004
    Los Angeles
    Clamav is a terminal program, it can be scary and confusing. ClamXav is a GUI frontend to Clamav. It is very simple effective and free. I highly recommend it.

    -llama :)
  7. CanadaRAM macrumors G5


    Oct 11, 2004
    On the Left Coast - Victoria BC Canada
    It's important to realize that Macro viruses are written in the Microsoft macro language that is shared between Office products on all platforms, so the Mac OSX is not immune to them.

    Yes it is something you should worry about, you will be transmitting this with every Word document you send out.


    After cleaning up as described in the posts above, you should be setting 'ON' your Macro virus protection in your Word preferences.
  8. The Red Menace thread starter macrumors member

    Sep 27, 2005
    I think i got them all. Clam AV is reporting none in my documents folder, and I changed the prefs so I will be warned in the future. Oh I also deleted the user data folder like stated above. Anything else? Thanks for the help.:D

Share This Page