Why are macs so slow to move files?

Discussion in 'Mac Basics and Help' started by Kronie, Mar 10, 2009.

  1. Kronie macrumors 6502a


    Dec 4, 2008
    So the mac came last night. everything is fine. Moved my files from my old windows backup drive to the desktop of my mac. About 250 gigs.

    But now moving files from my backup folder, on the desktop to say, music or pictures, is just as slow within the machine as if I were moving them through a USB connection.

    Is that normal for OSX? is there a faster way? Windows moves files within its OS, lightning fast.
  2. edesignuk Moderator emeritus


    Mar 25, 2002
    London, England
  3. Kronie thread starter macrumors 6502a


    Dec 4, 2008
    Drag and drop. It seems to be copying. How do you move files? Is it quicker?

    PS: This is the start of a million how to questions I'm sure I'll have.
  4. steveza macrumors 68000


    Feb 20, 2008
    If you move files on the same drive it is almost instant as the file does not actually move, it just appears in the new location in Finder/Explorer. If you copy files or move them from one drive to another (which is basically a copy then delete action) it's slower because a new file is being created.

    Copying/moving between 2 partitions on the same physical disk is always slow because the drive has to handle both read and write actions at the same time.

    The processes are pretty much the same for every operating system: OS X, Windows, UNIX, whatever.
  5. sammich macrumors 601


    Sep 26, 2006
    All of these files (your pictures/music etc.) that you copied from your old windows drive, you put them on your current users desktop? And did you then try to move these files from the desktop into the same users pictures or music folder?

    It should really be moving from what you're telling us, it only copies when the destination is a different drive or the ownership on the destination and original file is different.

    It would also be slower because it's copying from one location of the hard drive to another location on the same drive. Ie a lot of moving back and forward.
  6. és: macrumors 6502a


    Where are you moving the files from and where are you moving it to? If you're moving it from the the internal drive to the same partition on the same drive then it should be virtually instant.

    To move you simple drag from one location and drop in the other. It works the same way Windows works. Make sure you've got no keys pressed in when dragging and dropping.

    You are more than welcome to ask anything you like! Welcome to the forum and to Mac.
  7. Kronie thread starter macrumors 6502a


    Dec 4, 2008
    At this point its all on the same drive. Drag and drop is NOT moving the files though its copying and pasting.

    Something I'm missing?
  8. és: macrumors 6502a


    There must be something you're missing. Drag and drop (without holding any keyboard keys down) from the same drive to another folder on the same drive moves it instantly. I'm not even ware of any setting that can change this.

    Are you using the standard Apple mouse and keyboard that came with the computer. Make sure none of the shift, option (alt) or command (Apple) buttons are stuck down.

    You've not got a mouse with a strange rapid fire setting or anything, have you?
  9. neonblue2 macrumors 6502a

    Aug 25, 2006
    Port Pirie, South Australia
    Differing permissions perhaps? If a copy of the file is left inside the backup folder then you probably don't have write permissions on the folder. When you can't write, files are copied and not moved.

    To check, check the permissions on the folder (sing "Get Info"). It should say "You can read and write" if you have write permissions.
  10. xUKHCx Administrator emeritus


    Jan 15, 2006
    The Kop
    Permissions can change this. If you can only read the folder when dragging and dropping out of it the file / folder is copied by default.

    In terms of the OP select the folder and press cmd+I. When the window pops up check down at the bottom for the privileges associated with the folder. If it is Read Only (like the picture) then it will be opying the files by default (also noted by the green + by the cursor when you move a file). To change press the lock and select the Read Only and change it to Read And Write.

    Picture 4.png Picture 5.png
  11. Kronie thread starter macrumors 6502a


    Dec 4, 2008
    Apple site says Command-Drag should move to new location without copying but its not.

    It's a logitech mouse. I'm not sure why its not working. Its not a huge pain its just making the process take 4 hours, instead of 30 seconds.

    I try a restart after it slowly copies and pastes my 100 gigs of music....... 20 minutes left.......

    At least I can verify the move by the size of the two files?

    (Trying to find the silver lining here)
  12. és: macrumors 6502a


    I did think of that at first but, as it is a new Mac, dismissed it.

    I've got to run a I'm traveling to the football in a little while, but I'm sure one of the many great posters here will help you out.
  13. Kronie thread starter macrumors 6502a


    Dec 4, 2008
    That's not it. There all read-write already.

    So far everything I have tried that should work, hasn't.
  14. és: macrumors 6502a


    Don't hold anything down. Cmd drag is really for moving from one to another - and deleting the old version.

    Anyway, must dash now. Hope you get it sorted. It shouldn't be doing it and I don't believe will do it unless something is up.
  15. Kronie thread starter macrumors 6502a


    Dec 4, 2008
    Thanks everyone for the help.

    Part of the problem was the files were locked. so I unlocked all the files. Which worked for some files, but not all. I can individually drag and drop one file, and that works to move, but if I try to drag and drop more than one file it copies and pastes?

    I only have my pictures file left. and it will only copy and paste, so that's what i will be doing for the next hour or so.....

    It just didn't like those windows OS files on its desktop.:D
  16. Consultant macrumors G5


    Jun 27, 2007
    Get info on the main folder with your transferred files (Command+I), but not your harddrive icon!

    Change permissions
    Change lock status
    Select "APPLY TO ALL"

    Take few seconds to do.

Share This Page