Why are on-site backups taking up so much space?

Discussion in 'Mac OS X Lion (10.7)' started by Winter Charm, Jan 2, 2012.

  1. Winter Charm macrumors 6502a

    Winter Charm

    Joined:
    Jul 31, 2008
    #1
    I'm wondering why the backups kept by time machine are taking up so much space on my Mac's internal hard drive.

    I have them on an external hard drive, too, and I've done several routine backups there yesterday and today.

    Strangely though, I deleted some raw video clips (unedited - and only after copying them to two other locations) from my Internal Hard drive. For some reason, though, instead of freeing up disk space, the 80+GB of HD video were somehow turned into "backup" space. (See attached image).

    Is there any way to clean up the local backups, because I tried doing a backup to my Time Machine Disk, and it didn't seem to help the issue at all.

    I also noticed a line in the time machine settings that says the following:
    "Time Machine keeps local backups as space permits"

    My biggest problem is that I'm getting ready to import close to 150GB of video to work with (stabilize, edit, and export), so I really really need some free space on my hard drive!

    Can anyone help me? :(
     

    Attached Files:

  2. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #2
    For space issues, there are a few things you can try:
    • Begin by restarting your computer as a first step. This sometimes resolves issues.
    • Search with Finder to see if the space is being consumed by a very large file or several large files. Adjust the 50GB in the illustration to whatever size you deem appropriate.
      [​IMG]
    • For Time Machine users on Lion, Time Machine local snapshots may be consuming space.
    • Use DiskInventory X (pre-Lion), OmniDiskSweeper, JDisk Report or GrandPerspective to see how space is being used on your drive. Some of these apps may show more detail than others, so try several.
     
  3. Winter Charm, Jan 2, 2012
    Last edited: Jan 2, 2012

    Winter Charm thread starter macrumors 6502a

    Winter Charm

    Joined:
    Jul 31, 2008
    #3
    Thank you! It seems to just be the local snapshots and its causing a world of annoyance. I'm going to hope that they just disappear like the apple support page says they will after a week or so. Hopefully that's the case. If not, I'll see what has to be done.

    Also, a search for files greater than 1 GB didn't give me anything conclusive, just files that I already had and was aware of. and above that, nothing else.... lol
     
  4. theSeb macrumors 604

    theSeb

    Joined:
    Aug 10, 2010
    Location:
    Poole, England
    #4
    You can disable the local backups via the terminal, but I can't remember the exact command. It's documented in a couple of posts on this forum. I simply disable time machine completely and then hit the backup now button once a week when I've connected the external drive.
     
  5. thundersteele macrumors 68030

    Joined:
    Oct 19, 2011
    Location:
    Switzerland
    #5
    They will disappear. What you observed is exactly what happened: Time machine turns the deleted files into backups, in case you want to retrieve them at some point. The HD space is essentially freed up, e.g. if you use "Get Info" on your "Macintosh HD", it will list this space as available.

    My on disc "backups" was up to 15 GB at some point (quite a bit on a 128 GB SSD), after deleting a game. The space was freed up a week later.

    Apple claims that no local backups will be made if you are low on disc space and also that space is freed up prematurely if the disc space is needed. Not sure how well this works.
     
  6. MrAjsTech macrumors newbie

    Joined:
    Aug 22, 2012
    Location:
    Interweb
    #6
    Terminal Fix for Local Time Machine Backups

    I had this issue a long time ago with Lion on my older MBP with an SSD. At this time there was not very much resource to solve this issue. I just turned off time machine and waited. Now I had this again with my macbook pro on mountain lion. After searching a bit I found a terminal command that will do the trick and delete the unwanted backup files within minutes.

    Use the command in terminal: sudo tmutil disablelocal

    Simple as that. Hope this helped everyone. I cleared 15GB's on my rMBP.
     

Share This Page