Why are some icons on the lock screen?

Discussion in 'iOS 10' started by guychicago, Sep 12, 2016.

  1. guychicago macrumors 6502

    guychicago

    Joined:
    Jan 25, 2010
    Location:
    Chicago
    #1
    I'm using GM ios10 on my 6s. Does anyone know why the Whatsapp icon appears on the lock screen? Please see image.
     

    Attached Files:

  2. cwosigns macrumors 65816

    Joined:
    Jul 8, 2008
    Location:
    Columbus,OH
    #2
    Location-based suggestions for apps you use in your current location. It's been there since at least iOS 9, if not before.
     
  3. guychicago thread starter macrumors 6502

    guychicago

    Joined:
    Jan 25, 2010
    Location:
    Chicago
    #3
    How can I disable it?
     
  4. lagwagon Suspended

    lagwagon

    Joined:
    Oct 12, 2014
    Location:
    Calgary, Alberta, Canada
    #4
    You were right being since iOS 9. It's part of the Proactive Siri Suggested Apps introduced then. (They just share the same location on screen as the Handoff Apps introduced in iOS 8)
     
  5. theramod macrumors member

    theramod

    Joined:
    Dec 2, 2015
    #5
    Settings> iTunes & App Store> uncheck suggested apps
     
  6. guychicago thread starter macrumors 6502

    guychicago

    Joined:
    Jan 25, 2010
    Location:
    Chicago
    #6
    Don't see that option.
     
  7. imaginex20 macrumors 65816

    imaginex20

    Joined:
    Jun 17, 2009
    #7
    In iOS 10 they removed the handoff and suggested app settings. You can probably turn off the Location services option for Suggested apps locations.
     
  8. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #8
    And/or potentially even frequent locations as well.
     
  9. Shirasaki macrumors 603

    Shirasaki

    Joined:
    May 16, 2015
    #9
    Nope. Frequent locations is still there.
     
  10. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #10
    As in disabling them to get rid of the app suggestions.
     
  11. Shirasaki macrumors 603

    Shirasaki

    Joined:
    May 16, 2015
    #11
    Maybe also disable "location based suggestions".
     
  12. KALLT macrumors 601

    Joined:
    Sep 23, 2008
    #12
    That’s a beautiful wallpaper by the way. Where did you get it?
     
  13. willmtaylor Suspended

    willmtaylor

    Joined:
    Oct 31, 2009
    Location:
    A Natural State
    #13
    This is the one @guychicago
     
  14. segfaultdotorg macrumors regular

    Joined:
    Jan 25, 2007
    #14
    I disabled location based suggestions on my iPhone 6S and I'm still getting a suggested app cluttering up the lower left corner of the lock screen. I wish Apple had retained the option to turn this "feature" off in iOS 10.
     
  15. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #15
    Have you tried disabling "frequent locations" (and restarting afterward)?
     
  16. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #16
    I had to reboot before the settings changes took effect.
     
  17. segfaultdotorg macrumors regular

    Joined:
    Jan 25, 2007
    #17
    Seems to be working properly now that I've restarted. Thanks, everyone!
     
  18. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #18
    Well, it worked for me for a couple of days... but now it's changed tactic. Instead of saying "arrived at home" or "arrived at work" (blockable by turning off location services), it's now saying "good morning" and going by time. It's almost like it's deliberately trying to throw itself in my face at this point!
     
  19. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #19
    Don't really get why Apple removed options related to that in settings--they were already there, why not just leave them be.
     
  20. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #20
    I have heard back from Apple about this. The official way to disable this is:
    • In Settings/General/Spotlight Search, disable Siri Suggestions.
    • From the widget screen, scroll to the bottom, choose Edit, and remove Siri App Suggestions.
    This appears to work, at least for now, but I'll need to give it a few days to see whether it's gone completely.
     

Share This Page