Why are there random typos in a formatted email?

Discussion in 'Mac Basics and Help' started by ss957916, Jan 6, 2010.

  1. ss957916 macrumors 6502a

    Joined:
    Jun 17, 2009
    #1
    I've composed a 'press release' in mail with a couple of photos and some text all in a nice big box.

    But when I send it to myself (and others) it has some weird things: spaces in the middle of some words, random exclamation marks and at one point "&n! bsp;"

    Any ideas why this is? And how I can send a lovely formatted email that everyone will see as it should be?
     
  2. miles01110 macrumors Core

    miles01110

    Joined:
    Jul 24, 2006
    Location:
    The Ivory Tower (I'm not coming down)
    #2
    It's almost certainly something to do with going from a "WYSIWYG" sort of thing (like Mail Stationary) to basically anything else. Things get lost in translation. "&n! bsp" is probably "&nbsp" which is how a standard non-breaking space is marked up. It's pretty sad that even when viewed in Mail it doesn't show up properly, though.

    The short answer is you can't. If you want "universal" compatibility just use plain text, or make a webpage and send people the link.
     
  3. ss957916 thread starter macrumors 6502a

    Joined:
    Jun 17, 2009
    #3
    They'll edit HD video, they'll connect to the web, they'll store millions of music tracks, they'll edit high quality photos.... but they won't exchange formatted emails. Wow. Computers still have such a long way to go!

    Thanks. At least I now know.
     
  4. Darth.Titan macrumors 68030

    Darth.Titan

    Joined:
    Oct 31, 2007
    Location:
    Austin, TX
    #4
    Don't blame the computer, blame the developers of various email applications.

    When it comes to web browsing, everyone is all about standards compliance.

    When it comes to HTML email readers... not so much.
     
  5. XxEjGxX macrumors regular

    Joined:
    Dec 18, 2009
    #5
    its how they all read and format html slightly differently... best thing to do, is make like a blogspot blog and make it private[​IMG]then email your friends the link
     
  6. snberk103 macrumors 603

    Joined:
    Oct 22, 2007
    Location:
    An Island in the Salish Sea
    #6
    Plain text for content. PDF for looks. Though I suppose even PDFs can look slightly different depending on the viewer.

    If its a press release, stick with plain text so that the media outlet can cut and paste your words into something they will pretend to have a written, but at least your event is getting mentioned.
     
  7. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #7
    If you're interested in a more precise reason, what you're seeing is almost certainly a side-effect of poor handling of a quirk of the standard email format:

    The problem is that many programs that send email in HTML format--which, based on the chopped-in-half   yours does--just toss in those breaks wherever they occur. (Keep in mind that a line break, when part of an HTML document, just looks like a space when displayed.)

    I get one HTML email newsletter that will periodically have words with weird space in the middle due to this issue. In your case, your editor is using an   entity to insert a non-breaking space, but that fell across the 998 character max-line-length and got cut in half, so that you just saw two pieces of the raw code. I forget why, technically, the ! becomes visible, but it's a side-effect of the same problem (again, I've seen it produced by form-to-email scripts every 998 characters).

    Solution-wise, the question is already answered: If it's a press release, either format it as plain text, or attach a PDF if you're married to your layout and/or want to include graphics.

    [Addition: An alternate solution is apparently switching the message encoding to base-64, if that's an option in whatever mailer you're using. It will, apparently, encode the message such that the line length limitation is not a problem, so long as the mailer and receiver both support it.]
     

Share This Page