iPhone XS Why can only one number use iMessage in dual-SIM set up?

akash.nu

macrumors G3
May 26, 2016
9,047
10,684
Apple chose to implement it like that with least changes to existing implementation while adding a new feature, on the very first launch. They might extend functionality in the future.
 

Tom2D2

macrumors newbie
Sep 22, 2015
16
9
Michigan
According to Apple support document, you can’t send iMessage on the secondary line. Are you positive your texts on the secondary line are being received as blue?
Yes, for sure. However, so far, they are all with already established contacts. Time will tell if new contacts only come though as SMS texts on the second line (primary line is set for data and iMessages).
 
  • Like
Reactions: augustrushrox

davek000

macrumors newbie
Sep 23, 2008
7
4
I recently swapped from 2 x iPhones for personal/work to a single XS Max with eSIM and a physical SIM. I originally used the same iCloud account on both phones and could send/receive iMessage from both numbers on both phones. Now I can only send/receive iMessages on the primary number. It's a massive limitation for me and a real pain. I really hope Apple fix this soon as a single iCloud account can certainly work with more than one number associated - its what I used to do. So its just a software issue...

If anyone has a workaround / hack to enable both numbers on iMessage when using dual SIM then I'd be very keen to find out!
 

imlynxy

macrumors 65816
Mar 8, 2012
1,272
449
I recently swapped from 2 x iPhones for personal/work to a single XS Max with eSIM and a physical SIM. I originally used the same iCloud account on both phones and could send/receive iMessage from both numbers on both phones. Now I can only send/receive iMessages on the primary number. It's a massive limitation for me and a real pain. I really hope Apple fix this soon as a single iCloud account can certainly work with more than one number associated - its what I used to do. So its just a software issue...

If anyone has a workaround / hack to enable both numbers on iMessage when using dual SIM then I'd be very keen to find out!
They will fix it, but you have to buy faster and brighter iPhone XS-II (not ii , read it 2 :) , and hold it different )
 

bweb79

macrumors newbie
Dec 24, 2018
7
0
I have tested this also. I have a personal number setup as eSIM and Business number setup as Secondary. All my contacts, business and personal have the default line as personal. I don't know how to change this by bulk. Right now i would have to go into every contact and change the default to Business for all my business contacts.

I tried texting a coworker, the text sent as blue (iMessage). Turns out it used my personal number. The only way I have found to get it to use my work number is to change the contact to default to business. Then delete any messages I have from that person, and initiate a text to them. This is horrible.

Anyone find a better solution to this?
 

internetrando

macrumors 6502
Jun 5, 2018
458
258
Texas
I have tested this also. I have a personal number setup as eSIM and Business number setup as Secondary. All my contacts, business and personal have the default line as personal. I don't know how to change this by bulk. Right now i would have to go into every contact and change the default to Business for all my business contacts.

I tried texting a coworker, the text sent as blue (iMessage). Turns out it used my personal number. The only way I have found to get it to use my work number is to change the contact to default to business. Then delete any messages I have from that person, and initiate a text to them. This is horrible.

Anyone find a better solution to this?
Not anything I have found. What you describe appears to be the intended behavior.
 

Kingofclouds

macrumors member
Jul 31, 2011
71
37
I have tested this also. I have a personal number setup as eSIM and Business number setup as Secondary. All my contacts, business and personal have the default line as personal. I don't know how to change this by bulk. Right now i would have to go into every contact and change the default to Business for all my business contacts.

I tried texting a coworker, the text sent as blue (iMessage). Turns out it used my personal number. The only way I have found to get it to use my work number is to change the contact to default to business. Then delete any messages I have from that person, and initiate a text to them. This is horrible.

Anyone find a better solution to this?

What is worse is if that person sends a text message to your work number - it switches to business line and you can’t then iMessage them from personal until you delete the thread and start again.

I have been using the Hong Kong XS Max for the last two months (dual physical sims) - I was hoping the e-sim might behave differently
 

Kmatthews17

macrumors newbie
Feb 12, 2019
1
1
Yes, for sure. However, so far, they are all with already established contacts. Time will tell if new contacts only come though as SMS texts on the second line (primary line is set for data and iMessages).
Since they are already established contacts, the default number is your primary line. So if that contact was added to your phone when you only had your primary line, it will default to the number for calls and texts. Any numbers you add to your contacts or call/text after you set up dual sim will ask you which line you want to use, and you will probably notice when you chose secondary number for texts it will not send as an imessage
 
  • Like
Reactions: Kajkia

MyopicPaideia

macrumors 68020
Mar 19, 2011
2,069
873
Sweden
Isn’t there an option in iMessage settings to initiate new conversations from any email address instead of a number? I guess that doesn’t solve the problem of having to remove all the messages and set a default choice on a contact by contact basis...you’d have to choose your personal or business email as default...interesting one...and no real easy workaround...
 

Kajkia

macrumors newbie
Oct 17, 2014
2
0
Since they are already established contacts, the default number is your primary line. So if that contact was added to your phone when you only had your primary line, it will default to the number for calls and texts. Any numbers you add to your contacts or call/text after you set up dual sim will ask you which line you want to use, and you will probably notice when you chose secondary number for texts it will not send as an imessage

Thank you! This worked for me :)
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.