Why can't I boot from my HDD anymore??

Discussion in 'Mac Basics and Help' started by blueshogun96, Jul 20, 2016.

  1. blueshogun96 macrumors regular

    blueshogun96

    Joined:
    Nov 24, 2012
    #1
    I've been having a problem booting from this one HDD inside my Mac Pro for a few weeks now, and I have no idea why. Let me start off by stating what happened before this issue started.

    I have 4 OSes installed on this comp: Windows 8, Windows 10, OSX Yosemite and OSX El Capitan. While I was running the Win10 boot without any issues, I was running low on space in this partition so I decided to shrink the Windows 8 partition by 40GB. While that was successful, I couldn't extend that space onto the Win10 partition because it was not contiguous (I had no idea that was going to happen). So I didn't end up formatting it because I needed to restart my comp since Windows was bugging out (because Windows is always broken in one way or another). So instead of booting into Yosemite by default, it goes straight to El Capitan as if none of the other OSes or partitions were there! I don't remember how all the partitions were spread out across the HDDs I have installed. I just know that I really need to get back into these OSes because many valuable development projects are there.

    What have I tried? I've tried going to bootchamp and it didn't recognize any other paritions. I tried restarting and after getting into El Capitan, it told me that it didn't recognize a disk (which is apparently bad). Now, what I WOULD try if I could would be to hold the appropriate key during startup, but since I am using a stock video card (non-Mac EFI) I can't actually see that screen so it wouldn't really help. As a last resort, I can take out my HDDs, put them into my HDD caddy and plug them into other comps like my Macbook Pro or Laptop and see if they can read it.

    I'm really lost here. And of course, this really sucks. Any ideas? Thanks.

    Shogun.
     
  2. hobowankenobi macrumors regular

    Joined:
    Aug 27, 2015
    Location:
    on the land line mr. smith.
    #2
    Only a hunch, but I suspect that resizing the partition may have wacked the HD partition map. If this is the case....I don't have an easy fix for you. Whereas there are user friendly data recovery & drive repairs tools if this was a Mac/HFS+ volume only, I don't know of any easy system tools to help fix BC partitions or OSes. :(

    Two things moving forward:

    1. You should always backup important data, regardless of platform. I hope you have backups, you may need them.

    2. If your partition map is in fact nuked, and there is no recovering......next time you set up, consider using virtualization instead of bootcamp. One of the best things about virtual machines is that they are much easier to backup and restore than BC, not to mention much more portable. And you can easily use external drives too.​

    I hope a guru offers some wisdom about restoring BC partitions, or a way to make them bootable again with first hand experience. Stuff I found, but have not done myself:

    Help 1
    Help 2
    Help 3
    Use the trial version of NTFS for Mac
     
  3. keysofanxiety macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #3
    Yep, shrinking/extending BootCamp partitions just screws them up. Made that mistake once.

    If you can't see the partitions by holding Alt, I'm not sure if they would show when installing a custom EFI like rEFIt, though I don't think that even works on El Cap...
     

Share This Page