Why cant I get sound or vibration when receiving new mail?

Discussion in 'iPhone Tips, Help and Troubleshooting' started by BA005, Aug 21, 2008.

  1. BA005 macrumors newbie

    Joined:
    Mar 21, 2008
    #1
    I just became the owner of an iPhone 3G and am very pleased with it all round. Especially as in Japan, the plan with SoftBank is very reasonably priced.

    But there is one thing that is really, really, really bugging me. I dont seem to be able to hear a sound or feel a vibration when I receive a new mail. When I receive a mail, this appears on the screen..

    [​IMG]

    But there is absolutely no sound or vibration when it does that!! If this happens when the phone is on my desk or in my pocket or bag, or basically anywhere where my eyes are not fixed on the screen, how the bloody hell am I supposed to know that I have received a new mail??!!

    I am a bit worried about this, because I am a heavy email user when it comes to mobiles.

    Any advice would be appreciated.

    Thanks.
     
  2. dalvin200 macrumors 68040

    Joined:
    Mar 24, 2006
    Location:
    Nottingham, UK
  3. BA005 thread starter macrumors newbie

    Joined:
    Mar 21, 2008
    #3
    Thanks, but it's already on
     
  4. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #4
    Hmmm, the software for the Japanese iPhone I guess is slightly different (there isn't an e-mail minder like that on the US iPhone, AFAIK?).

    But I've seen so far, with 2.x, there are some bugs in the iPhone software that sometimes cause these sounds to be suppressed. Like occasionally I do not get keyboard clicks at the lock screen when it is turned on, etc. For this reason, perhaps you might try re-installing the firmware (restore the firmware) using iTunes? You should be able to right click on your phone in iTunes and restore the data (it's a little confusing, but after you restore the firmware, you need to do two steps to get the phone back where it was -- one is to sync the phone, and the other is to restore the backup data, which puts SMS back on the phone, restores Contacts, settings, etc.)
     
  5. BA005 thread starter macrumors newbie

    Joined:
    Mar 21, 2008
    #5
    Cheers, I will give that a try.

    Is this a problem that might be able to be fixed with a software update in the future?
     
  6. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #6
    If my description / analysis is correct, yes. It was a problem that didn't exist in the 1.1.x software on the first gen iPhone, so I suspect it should be something Apple knows about and will fix.
     
  7. darkfiber macrumors 6502a

    darkfiber

    Joined:
    Jul 13, 2008
    Location:
    Columbus, OH USA
    #7

    When I don't hear the clicks when typing on the the lock screen I just power off the phone and when it starts back up it works fine. I doubt going through all the hassle of reinstalling is going to fix the issue. Apple is going to have to fix this bug in a future firmware release.
     
  8. jschuur macrumors newbie

    Joined:
    Jun 26, 2007
    #8
    I've got the same problem with not getting a new email notification sound, even though it's turned on in the options. Vibration works when that option is on, but I almost never hear the new email sound, and I did a reinstall (although that was for reinstalling 2.0.1 when that was still current.

    The problem hasn't gone away in 2.0.2, and I'm tempted to do another reinstall here soon.
     
  9. stupod macrumors newbie

    Joined:
    Jun 6, 2008
    #9
    Softbank custom email notifications

    I've been well aware of this problem since the day I got my iPhone in Japan but I've hesitated posting about it because I knew it would be a pretty long post.

    So, I apologise in advance, this will be a long post.

    If you can't be bothered reading it all, the short version is this: Either stop using your @i.softbank.jp address and use Yahoo or MobileMe instead OR start complaining to Softbank/Apple and get them to either start using actual push email for @i.softbank.jp addresses or get them to fix the custom notification implementation so that it uses audio/vibrate (then get Apple to extend the audio/vibrate notification!).

    I've had the original iPhone since its first release last year so I'm not new to it all.

    I think there are potentially quite a few reasons this is the way things are.

    First and foremost would be that Japan is the only country (that I know of) where your phone carrier gives you an (@carriername) email address when you sign up. People in Japan use email on their phones very differently from the rest of the world. For example:

    • SMS isn't usually called SMS here. Different companies have different names for it. AU (KDDI) calls it C-mail, Vodafone (now Softbank) called it Skymail. I'm not sure what the others call it but I'm sure they have their own names for it too.

    • SMS (C-mail, Skymail, whatever you want to call it) in Japan generally can't be sent to phones on other carriers. It's used for sending SMS to phones on the same carrier/network and is considerably cheaper than SMS in other countries.

    • People in Japan use email (not SMS. Actual email using their @carriername email address) on their phones to send to phones on other networks, to normal non-phone email addresses (Gmail, Hotmail etc) and to phones on the same network when the email requires more than the SMS character limit. They use this type of phone email much more than phone users in other countries from what I've seen and heard.

    • A lot of Japanese don't have computers and don't use non-phone email addresses (Gmail, Hotmail etc) for sending email. They do it all on their phone.
    Second reason. The Japanese mobile phone industry is quite insular. Japanese phones aren't generally exported. They're made to work with Japanese carriers using features common in Japan but not elsewhere. Evidence of some of these points here. When you buy a new Japanese phone with a Japanese carrier, there are no customisations the carrier is required to make to get that phone working with their systems, because they're made for the Japanese market and carriers.

    The main point of this second reason is the iPhone did require at least one customisation by Softbank and that's the email notifications. The Softbank email service (for any of Softbank's phones, including the iPhone) doesn't use actual push.

    Someone in the Japanese phone industry once explained to me how it works but I can't remember the exact technical details. When an email is sent to a Japanese phone (except the iPhone) it does immediately notify you and it does immediately download the email, just like push. It's not using push though. It's using something else. Sorry, I can't remember the name or the details and can't find any details about it on the intarblogs!

    It does seem that the iPhone at least partially supports this behaviour, as evidenced by the 'You got a mail.' screen. That message shows within a few seconds of a mail being sent to the @i.softbank.jp address so the Softbank network is definitely instantly notifying the iPhone that there's new mail, much like push.

    That screen doesn't appear on non-Softbank iPhones because outside of Japan people don't have the @carriername email addresses.

    The text 'You got a mail.', the big green 'Dismiss' button and the general design of the screen suggests that Softbank either did this part of the UI entirely themselves or at least had a lot of input. The English text is grammatically incorrect and the 'Dismiss' button doesn't feel like something Apple would do. 'Dismiss' at first suggests that you're at least dismissing the email, or perhaps even deleting it.

    Because it looks like Softbank built this part of the notification system, it shouldn't be a surprise to anyone that it's not working perfectly. They're not the best phone company in the world and they're dealing with a brand new 'type' of phone, quite unlike Japanese phones.

    Because Japanese phones are built for the Japanese market and carriers, it's also probably the first time a Japanese carrier has had to make any sort of customisation to get it working. That's possibly another part of the reason it's not great, because it's new and they haven't worked it out yet.

    Third reason. I wouldn't be surprised if this is the main reason there's no audio or vibrate notification at the same time as the 'You got a mail.' screen. Because Softbank are not using push, and the 'You got a mail.' notification isn't part of the usual iPhone UI, or the Mail.app, or mail in general, there would be no way for a user to customise this notification.

    If Softbank altered the current 'You got a mail.' notification so that it vibrated and played audio, how could the user change the audio that plays or any other settings related to this notification?

    Some might say you should be able to change it in Settings > Sounds but those settings are currently only for Mail.app actually receiving mail, not this non-standard stuff Softbank are using.

    I can see why Softbank might think that no audio or vibrate notification is better than having them and the user not being able to change them, but I think I'd disagree.

    So, as far as I can tell the only options for making things work the way they do on all other Japanese phones are...

    1. Complain to Softbank about the current system. A friend and I have already spent quite a while speaking to Softbank staff in a store, Softbank Customer support by phone, plus their managers. We both speak Japanese well and explaining the problem and listening to their responses was easy. Some of them didn't understand the problem at all but the ones who did mostly responded with "Yes, that's how it is". They didn't even seem to understand that it was a complaint and that we want something done about it. If you want to call and complain (please do!) you can call 157 (press 8 for english support if you need it).

    2. Stop using your @i.softbank.jp address and switch to Yahoo or MobileMe. This option sucks a bit for a lot of reasons. Though Yahoo does work, it's not "real" push apparently. MobileMe works but of course Apple are having problems with it, plus it costs $99USD a year. The main problem with this is actually quite massive, and will probably remain a problem even if Softbank fix this whole thing. You can't customise the notification for new email at all (WTF Apple!?)! It vibrates ONCE and plays a short tone ONCE. The whole notification last about half a second. I'm very surprised there aren't a lot more people complaining about this. It seems like a massive issue to me! There is an app called 'asVibra' for extending the vibrate/audio notification for new SMS which just changes a number in a plist file. I do wonder if the same can be done for the email notification. As soon as I've jailbroken my new phone I'll search for it and reply if I find anything. It will also be interesting to see if there's any evidence of the Softbank text only implementation, and even more interesting would be if someone could actually alter it and make it play audio! I doubt it though...

    3. ???
    Anyway, this whole @carriername new email notification thing is a bonus compared to the rest of the world and in a way it's surprising there's any notification at all. Still, it'd be great if it could be improved.
     
  10. edtorious macrumors 65816

    edtorious

    Joined:
    Aug 14, 2007
    Location:
    San Diego, California
    #10
    hmmm, i noticed you're watching a video when u got the notification, could that be the reason? try sending yourself email without doing anything in your iphone and see if you get any sounds or vibe.
     
  11. stupod macrumors newbie

    Joined:
    Jun 6, 2008
    #11
    The same screen shows regardless of what the phone is doing and it doesn't vibrate or play audio in any situation. It also doesn't make any difference if all the settings in Settings > Sound are turned on or off, the volume is up or down, or if the silent switch on the side is on or off. It's not attempting to do anything but show that 'You got a mail' screen.
     
  12. stupod macrumors newbie

    Joined:
    Jun 6, 2008
    #12
    Possible solution

    I've found a possible solution and I'm quite happy with it so far (it's only been 1 day so far).

    I stopped using my @i.softbank.jp email address and switched to a Yahoo address because Yahoo email is push now and Softbank may never get it together.

    I jailbroke my iPhone 3G and overwrote /System/Library/Audio/UISounds/new-mail.caf with my own file and it makes the new mail notification very obvious. It even seems to automatically extend the length of the vibrate too which is nice, though odd.

    * The 'new-mail.caf' file is just a AIFF file with the extension changed.

    * I did a backup of the original 'new-mail.caf' file before I overwrote it.

    * If your iPhone is on silent it will still only vibrate once with this setup.

    * A rather easy way to make a AIFF file for this is to open your audio file in Quicktime then go to File > Export. Choose 'Sound to AIFF' in the 'Export' field, then click the 'Options' button to the right. Make the options screen look like this, then export. Either save it as 'new-mail.caf' then transfer it to your phone or save it as 'whatever.aiff' then rename it to 'new-mail.caf'.
     
  13. Keynes macrumors newbie

    Joined:
    Aug 30, 2008
    #13
    Why cant I get sound or vibration when receiving new mail?

    Hi Guys,
    Thanks, thanks and thanks for opening this thread. I'm having a big trouble with iPhone 3G Softbank. Whenever I get a new message, I get a similar screen as the one posted by Edtorious. But the problem is, when I click on 'dismiss', the message disappears and my Inbox doesn't include any new message. I've tried not to click on 'dismiss', but I can't access anything else until I click on this notification.
    May be because of this, I can get mails, except SMS.
    Thanks ain advance
     
  14. stupod macrumors newbie

    Joined:
    Jun 6, 2008
    #14
    Keynes, that 'You got a mail.' screen is not to tell you that new mail has been downloaded. It's only to tell you that the Softbank server has new mail for you. You still need to click the 'Dismiss' button then open the Mail app to download the new email. It's also worth noting that unlike other Japanese phones, Softbank don't setup the email account on the phone for you. You need to go to Settings > Mail, Contacts, Calendars > Add account to setup the account yourself.

    During the setup it will show you an alert which looks like this. It might even say it twice. Tap the 'Yes' button to setup the account without SSL and it will work. Expect it to take a minute or two to setup.

    Also, if you haven't already changed your email address to something better than what you were issued, you can do it here.

    The 'Dismiss' button is also a good example of bad English. It should really say something like 'OK'.
     
  15. crayonshin macrumors member

    Joined:
    Mar 10, 2008
    Location:
    Japan
    #15
    I tried Yahoo and the "push" works fine, BUT, I found that if I sent emails in Japanese to my friends with AU phones, they would just get garbled text. I've heard that AU still uses Shift JIS encoding so that could be the reason since Yahoo only encodes in UTF-8 I'm assuming. These friends have pretty old phones though so maybe newer AU phones are fine. Anyway, I tried MobileMe and that worked fine so I guess I'll stick with that. I had already changed my email alert sound and vibration duration (and SMS too) but I still needed real PUSH email to activate them. Another thing I did was setup my MobileMe mail to automatically forward to my SoftBank mail so I get my custom alert/vibration AND the "You Got A Mail" popup.

    I really hate the idea of paying for something that's standard on all other Japanese phones though. I've read a few sites where some people think Apple "persuaded" SoftBank to half-ass it like this so they could sell more MobileMe subscriptions. I guess if I'm any indication, it's working.
     
  16. stupod macrumors newbie

    Joined:
    Jun 6, 2008
    #16
    Why are you paying for MobileMe? Because of the Japanese text encoding when sending to AU phones? From what I've read the problem there is with AU, not the iPhone or Softbank or Yahoo or MobileMe. If you only want push and email to AU phones, a free Yahoo account will give you that, right?
     
  17. Keynes macrumors newbie

    Joined:
    Aug 30, 2008
    #17
    Hi Stupod,
    Many thanks for your help. Actually, I set up a different email account than the one set by Softbank. I've just tried to retrieve my emails from the softbank server but the iPhone keeps displaying 'connecting' for 15 minutes without any result. Do you need Wi-Fi before retrieving emails? Do I have to turn on or off the 'use of SSL' in Settings>Mails>@softbank>Advanced?
    One more thing, how should the yahoo or Gmail settings look like for them to work in iPhone?
    Thanks a lot for your time!
     
  18. stupod macrumors newbie

    Joined:
    Jun 6, 2008
    #18
    You don't need to turn on Wi-Fi and you do need to turn off SSL in both SMTP and advanced.

    During the Softbank email setup in Settings > Mail, Contacts, Calendars > Add Account you need to tap the 'Yes' button on the screen which looks like this.

    If you still get errors when trying to send or receive email for your Softbank account, go back to Settings > Mail, Contacts, Calendars and select your Softbank account. Scroll to the bottom and tap the 'SMTP' button below the 'Outgoing Mail Server' heading. At the top of the page it should say 'Primary Server' then a button saying 'smtp.softbank.jp On >'. Tap that button, scroll to the bottom and turn off 'Use SSL' if it's turned on.

    Now go back two pages using the button at the top left of the page, then select the 'Advanced' button just above the red 'Delete Account' button at the bottom of the page. Scroll to the bottom of the page and once again turn off 'Use SSL' if it's turned on.

    You can now press the Home button and open up the Mail app and things should be working.

    To setup a Yahoo or Gmail account properly, just select the Yahoo or Gmail buttons after selecting the 'Add Account' button, instead of selecting the 'Other' option. As long as you do that, they will be setup properly.
     
  19. Keynes macrumors newbie

    Joined:
    Aug 30, 2008
    #19
    Hi Stupod,
    Thanks a lot, a lot. Yahoo, Google and softbank account are now working. Still, my company's email account isn't. It can receive emails but fails to send; but I should forget about it for the time being and live happily with what I've got.
    Once again, many thanks.
     
  20. Keynes macrumors newbie

    Joined:
    Aug 30, 2008
    #20
    Error message "Cannot connet to ITunes store" while WiFi "on"

    I'm having some trouble with my iTunes and App Store. My WiFi is on and showing a strong reception. The buttons at the bottom (featured, top tens, search, downloads) do highlight when i tap them but nothing appears on the screen ..just the error message "Cannot connet to ITunes store".
    Also, when I click on either iTunes or App Store, the wifi signal sign disappears. Thanks in advance for your help.
     
  21. stupod macrumors newbie

    Joined:
    Jun 6, 2008
    #21
    Hi Keynes,

    It sounds like that question should be posted in a different forum or thread. This one is specifically about Softbank users email notifications.
     
  22. Akiki macrumors newbie

    Joined:
    Sep 13, 2008
    #22
    Soundless Notification

    The screen that you posted a shot of is actually the push notification screen. You can't hear any sound, because there is none. For some people, depending on the area you're in, the phone can connect quickly and download the mail automatically. Those, however, are 2 different functions. I live in Japan kind of out in the country, so all of my mail accounts on the iPhone are rarely automaticaly downloaded. The silent notification has to do with the iphone software and nothing to do with the carrier.
     
  23. stupod macrumors newbie

    Joined:
    Jun 6, 2008
    #23
    Yeah, that's wrong.

    It's not the push notification screen. Test it for yourself. Make sure you have the silent switch on the side of the phone disabled so you can hear notifications, make sure you have the 'New Mail' notification in Settings > Sounds turned on, setup a push account such as MobileMe or Yahoo then send yourself an email. You get a short sound and a vibration, but no on-screen notification except for an updated number on the Mail icon when you next turn on your phone.

    You're also wrong about the screen I posted. It is a carrier setting and there are easy ways to tell. First would be to use the method I just mentioned above by setting up a push email account. The notification is completely different. Second would be to delete or disable your current Softbank email account on your iPhone. Now send an email to that address. You still get the same 'You got a mail.' screen that you get when you do have the account enabled. That means it's nothing to do with having a push email account setup, or any email account setup at all. It's all to do with the carrier settings.

    If you want video to prove it, I'd be happy to make it...
     
  24. mavis macrumors 68040

    mavis

    Joined:
    Jul 30, 2007
    Location:
    Tokyo, Japan
    #24
    You're absolutely right - I've NEVER had SoftBank's garbage mail set up on my iPhone, but I bounce mail from several low-traffic and somewhat inconsequential email accounts to my SoftBank address solely for that notification. That way I can disable push/fetch and I can avoid having to even manually check those accounts for new mail, unless I get that stupid pop up.

    TBH, though - I don't really know why this is a big deal to anyone anyway - I mean, who wants to be dependent on a SoftBank email address?? I have always found it annoying and inconvenient to have to send emails to all my family/friends every time my email address changes (which is inevitable if I use the SoftBank mail), and since I don't plan to live in Japan forever, I hate the idea of having to depend on SoftBank's email for much of anything. That's what my personal domain is for, or even my MobileMe account. Just a thought.
     
  25. jawful macrumors newbie

    Joined:
    Sep 19, 2008
    #25
    Just to reiterate what stupod said, this isn't correct. The message is in English and Japanese because it's unique to Softbank. Also, there are bugs with that screen showing just how hacked it is. Have any of you ever experienced the black screen bug where your main apps screen is blank? You have to go to the 2nd page and open a new app to get it back. This is 'cause of that BS, in your face but doesn't actually help you, notification screen.

    Also, the "dismiss" wording is much better when the phone is set to Japanese, being 了解 (ryoukai, more or less means "got it"). This hacked up "feature" without providing a real solution is bs. Not happy at all.

    Edit: You can log into "My Softbank" and turn off the message, if you want to... of course, it's the only notification so turning it off seems silly.

    HATE the idea of switching to a yahoo address. My keitai address is my keitai address. Period. I don't want to give people a yahoo address to mail me at. grr

    edit: OK I have a (hopefully temporary) solution. Read some stuff about Mobipush (https://www.mobipush.com) and it technically works/pushes to the iPhone. However, it doesn't support deleting of messages or reading the body on the iPhone. Sounds worthless. But if you continue to use your account via normal IMAP as well and only use Mobipush to give you notifications, it's much faster than having your phone fetch every 15 min and then no wasting battery when you have no mail. You just have to put up with a dummy account. Not ideal, but seems to work for now.

    Also, found a bug. See if you can recreate it. Have you phone on the Home screen. Then send yourself a mail (from computer or whatever). When it comes up with the "Dismiss" screen, don't touch it. Let it go to black/lock your phone. Then unlock it and dismiss the message. Are you at that black screen with no apps? To get out of this horror, slide to another screen of apps, open one, then close it. Everything should be back. But god damn if that isn't annoying.

    I attached pictures about the bug. Picture 1 is when the notification comes. Picture 2 is after you've let it go black then unlock it. Picture 3 is the result of hitting "Dismiss". Picture 4 is moving to the next page of apps. Picture 5 is after you've gone into an app and then closed it again. Easily reproduce-able.
     

    Attached Files:

Share This Page