Why can't I get to single user mode?

PaulFXH

macrumors member
Original poster
Aug 31, 2007
66
2
I'm using a 1-y-o MacBook (2.16 GHz, C2D)with fully updated Leopard.
Besides OS X, I multiboot (using rEFIt) a number of Linux OSes.
Right now, I'm trying to get into single user mode in OS X. So, I reboot, hold down +s and then click on the Apple icon in rEFIt.
I am immediately brought to a shell after what appears to be no booting at all.
In this shell, if I type
Code:
/sbin/fsck -y
I get a message telling me that /sbin/fsck is not a recognized command etc.
So, even though +s does bring me to "shell", nothing whatsoever works in this shell. Not even "reboot".
The only way to get out of it is to do a hard reboot.

I've also tried +v (verbose) on booting. This indeed does induce some verbosity, but it ends up booting to the normal OS X.
I have a feeling that rEFIt is interfering with my ability to get to a single user mode.

Can anybody please help me resolve this?
 
  • Like
Reactions: grahamperrin

czardonic

macrumors member
Feb 6, 2008
38
0
My wife is also unable to boot into single-user mode, on her AGP450, running 10.4.11. Other than that, it's pretty much plain vanilla.The machine is upgraded with a 1.4Ghz processor, for what it's worth.

Her computer, using Command + s, unfailingly causes it to start up in Classic (OS 9)

She's trying vainly to run Applejack.

I know this is of little consolation to you, but thought you, and OTHERS, including Apple, should know. Apple is being notified as well -- for all the good that will do.
 

PaulFXH

macrumors member
Original poster
Aug 31, 2007
66
2
Thanks for your reply.
It seems my inability to get to single-user mode is caused by rEFIt. The shell I get to with +s is the EFI shell, with which you can do very little, rather than an OS X shell.
So, looks like for moment I'm just going to have to tolerate this as I like rEFIt.
 
  • Like
Reactions: grahamperrin

kiwidesign

macrumors newbie
Nov 17, 2008
26
3
hello everyone!

sorry for bumping, but I have the exact same problem: I would like to access OSX single user mode without disabling rEFIt! there isn't any keyboard shortcut to access the standard OSX booting options?
 

kiwidesign

macrumors newbie
Nov 17, 2008
26
3
Try holding Command+S when you boot up the system.
unfortunately this doesn't work... the rEFIt bootloader bypass the normal OSX shortcuts! holding cmd+S goes to EFI shell again...

the thing is that "single user mode" should still be there, but I have no clue on how to get there... :confused:
 

thefilmmaking

macrumors newbie
Dec 2, 2008
17
0
Solution

I was having the same problem and wanted to share the solution.

Do not press CMD + S until AFTER you have selected Mac OS X to load. The trick is to immediately press CMD + S right after you select Mac OS X to load. And by right after, I mean RIGHT after. As quick as you can. Then it loads into single user mode and all the commands work.

Hopefully this helps some of you. Take care.
 

mackmgg

macrumors 65816
Nov 2, 2007
1,414
37
try selecting your hdd in rEFIt and pressing f2. there are a few options that come up not sure if that is one of them. if that doesnt work just turn off your computer by hard restarting instead of the right way and it disables rEFIt (at least on my computer.
 

Sun Baked

macrumors G5
May 19, 2002
14,859
57
The key modifiers happen after the initial boot sequence loads the first phase of the boot from BootX.

That is if the EFI machines are set up anything like the PPCs, where the key sequences aren't part of the actual ROM on the motherboard, but part of the boot process loaded off the drive.
 
  • Like
Reactions: grahamperrin

bblevins

macrumors newbie
Dec 17, 2008
1
1
I live where I stand
The Right Answer

try selecting your hdd in rEFIt and pressing f2. there are a few options that come up not sure if that is one of them. if that doesnt work just turn off your computer by hard restarting instead of the right way and it disables rEFIt (at least on my computer.
mackmgg is correct.

To boot into single user mode with rEFIt:

At the rEFIt main menu:
Highlight the OSX boot partition (the big blue apple)
Press F2

Boot options will appear:
Select 'Boot Mac OS X in single user mode' and press enter.

(posted for posterity should others have the same problem, Like me!)
 
  • Like
Reactions: grahamperrin

matsclasss

macrumors newbie
Sep 1, 2016
1
0
try selecting your hdd in rEFIt and pressing f2. there are a few options that come up not sure if that is one of them. if that doesnt work just turn off your computer by hard restarting instead of the right way and it disables rEFIt (at least on my computer.
Thanks this is exactely what i was looking for ;)
 

grahamperrin

macrumors 601
Jun 8, 2007
4,942
642
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.