Why Can't I install Leopard on my MacBook

Discussion in 'macOS' started by CyberBob859, Jan 7, 2008.

  1. CyberBob859 macrumors 6502

    Joined:
    Jun 13, 2007
    #1
    I've been trying to install Leopard on my Macbook, but I'm running into a lot of problems. I think it's my Combo drive, but would like some other opinions.

    My Macbook is the "late 2006" model - 1.83 Ghz Core Duo, 2GB of RAM, the combo drive, and an upgraded 120 GB WD hard drive. It has OS/X "Tiger" installed (10.4.11) and all updates. It runs flawlessly.

    The first time I inserted the Leopard disk into my Combo drive, the drive spit out the disk after about a minute. I tried again, and the disk mounted. With the Leopard disk in the drive, I restarted the machine. It took FOREVER (about 5 minutes or more) before I finally got to the screen that asks me what language I want to use for the install. After a couple of clicks, the install seems to proceed, but then I get a message that the disk couldn't be read, and recommended that I clean the disk.

    I cancelled the install, ejected the Leopard disk, cleaned it with a disk cleaner I had, and proceeded with the installation again.

    I then got to exactly the same spot and got the same message - clean the disk. Not good.

    I took the Leopard disk and my Macbook to the local Apple Store. They tried my disk on one of the new iMacs, and it proceeded fine - got past the point I was getting stuck on. They deemed my Leopard disk as OK - not defective.

    When I tried to duplicate my problem in front of them, I actually got an error message, which (when looking at the log), they interpreted as a bad hard drive. (I didn't think so, but wasn't going to argue with them) So they said "either your hard drive or combo drive is failing."

    I then tried DiskWarrior 4, trying to boot from the CD. I started getting problems trying to boot from that disk. DiskWarrior's tech support said that I should "clean the CD." Hmmm.....

    However, in this case, cleaning the disk was successful. I was able to boot from the DiskWarrior CD, and performed a check on the hard drive. It found some errors, corrected them, and when testing the hard drive itself (through S.M.A.R.T), it said it was fine - no problems.

    So, I tried one more time to install Leopard. Unfortunately no go - I got to the same spot and it said I should clean the disk because it couldn't read from it. I cleaned the disk again, installed again, and again got nowhere.

    I really think I have a Combo drive issue, but this drive hasn't given me any problems. I can play DVD's. I can rip CD's. I've burned CD's fine. I did a fresh install of Tiger way back when with no problems. It just can't seem to read this Leopard DVD, but other Macs can.

    What do you guys think? Bad Combo drive? Or are there other things I can try?
     
  2. jwt macrumors 6502

    Joined:
    Mar 28, 2007
    #2
    I've had this problem several times. In my case, I popped the CD into another of my computers and it worked flawlessly. The solution in my case was to use the second computer to make a duplicate CD and use that to install on the original machine. No problem.

    I'll add that I don't think you have a problem with your drive. This issue happened to me twice spread across two machines, but only once on each.
     
  3. CyberBob859 thread starter macrumors 6502

    Joined:
    Jun 13, 2007
    #3
    Never thought of this!

    This is a good idea. I'm going to try making that second DVD to see if my Macbook can read that disk. Thanks for the tip.
     

Share This Page