Apple TV why can't I jailbreak my ATV2?

Discussion in 'Jailbreaks and iOS Hacks' started by mdwsta4, Feb 15, 2011.

  1. mdwsta4 macrumors 65816

    Joined:
    Jul 23, 2007
    #1
    I've been jailbreaking iphones since you had to type in code, yet for some reason I can't get greenpoison to work for me!
    downloaded the latest version and also downloaded xbmc and plex. plugged my atv into my mbp using a micro usb. plugged in the power. pressed and held menu/play/pause until it prompts then releases. It's not entering DFU mode, just saying 'try again'.
    I've also pressed menu/down to reset atv and tried again and again. WTF? Do you really have to plug in the usb then the power or can you simply plug both in at the same time before running the jailbreak? I've tried both ways, but figured it's worth asking.

    all I'm trying to do is jailbreak so I can play avi files.
    thanks!
     
  2. Dannymonky macrumors member

    Dannymonky

    Joined:
    Feb 6, 2007
    Location:
    Rats Mouth, Fl
    #2
    Try plugging in USB first and wait for flashing lights(a couple of seconds)then plug in power.

    Are you Jailbreaking a fresh 4.2 install or jailbreaking over a Season pass JB?
     
  3. mdwsta4 thread starter macrumors 65816

    Joined:
    Jul 23, 2007
    #3
    tried that, still no go.

    I plugged it back into my TV and show it's only on 4.1.1, however when I go to check for updates, it states that my firmware is up to date. 4.2.1 added airplay among other things, correct? but i can use airplay with my atv and ipad already so that's odd.

    using this link: http://www.newsden.net/jailbreak-4-2-1-ios-apple-tv-2g-greenpois0n-rc6-6553/
    I downloaded 4.2.1. Do I manually add this firmware onto ATV through itunes like i would a custom firmware on iphones?
     
  4. owine macrumors member

    owine

    Joined:
    Oct 29, 2008
    #4
    The ATV is running software version 4.1.1, but is running iOS 4.2.1. If you click OK a couple times on the about screen it will reveal this difference.

    As for the jailbreak, make sure it is a fresh restore and just keep trying is my best advice. It took me a few tries but I eventually got it.
     
  5. mdwsta4 thread starter macrumors 65816

    Joined:
    Jul 23, 2007
    #5
    did a complete restore of the device. have tried the steps again and again and again. I'm at at least 2 dozen attempts. makes no sense why it isn't working and is extremely frustrating.
     
  6. margotspop macrumors regular

    Joined:
    Jan 12, 2004
    #6
    Why not try the tethered jailbreak first with SeasOnPass to see if the problem lies with your ATV or with greenpoison. Once jailbroken I've found the tethered JB to be a non-issue - it's not a big deal for me to take my laptop down to the TV room and hook it up. I've only had to do it a couple of times.
     
  7. noobinator macrumors 601

    Joined:
    Jun 19, 2009
    Location:
    Los Angeles, CA
    #7
    I was having issues with my mbp picking up my atv2 clicks so it worked after I disabled it.
     
  8. mdwsta4 thread starter macrumors 65816

    Joined:
    Jul 23, 2007
    #8
    Well perhaps at this point it is my atv. am trying the same thing with seasonpass and am having the same problem (cannot get into DFU mode). i've tried holding for exactly 7 seconds, longer, shorter, with power, without power, etc, etc.

     
  9. noobinator macrumors 601

    Joined:
    Jun 19, 2009
    Location:
    Los Angeles, CA
    #9
    Connect power and usb.
    open itunes.
    click to run greenpoison, dont need to click start or whatever it says
    unplug power
    hold down down and menu for 7 seconds
    hold down menu and play/pause for 7 second
    release
    plug in power while jailbreaking

    I think this is what worked for me.
     
  10. X-rated macrumors member

    Joined:
    Apr 30, 2010
    #10
    For myself I tried using the power cord as directed (about 30 times unsuccessfully) as soon as I tried it our I mean the first time without the power cord it worked flawlessly. There is no reason to use the power cord it is a POWERED USB.
     
  11. shavermcspud macrumors member

    Joined:
    Mar 25, 2008
    Location:
    Cambridge UK
    #11
    I tried for hours over the weekend to jb my new atv2.

    Here what i did.

    I didn't bother with plugging and unplugging usb power etc.
    I plugged the whole lot in, usb and power waited until it was booted up with light constantly on all plugged in with itunes closed

    Held down the menu button and the down arrow on the remote until the light flashes quickly, let go of the down button and hold the play/pause button not letting go of the menu button for a further 6 seconds until the light flashes quickly again then i had the steady blinking light indicating dfu mode.

    The problem i had was my usb cable, it was the correct type but only found out after hours that it was in fact just a phone charger cable and the internal wiring only had the +5v feed and not the usb data so green pois0n kept failing, bought a new cable and bang straight away it worked.

    Worth a check
     
  12. Phil A. Moderator

    Phil A.

    Staff Member

    Joined:
    Apr 2, 2006
    Location:
    Shropshire, UK
    #12
    I've found the ATV is very picky about USB cables - I haven't tried jailbreaking but have updated my ATV to the latest beta.

    I've got about a dozen micro-usb cables from various devices lying around and the only one that would work and let iTunes see the ATV was the one from my Kindle:

    All the others seemed to work fine in that the ATV powered up but it didn't appear in iTunes
     
  13. jiminfrance macrumors newbie

    Joined:
    Jul 22, 2004
    #13
    There is a warning that comes up in greenpoison that tells you to wait 40 seconds after you have finished jailbreaking before disconnecting. I missed this the first couple of times I tried, but when I waited my ATV2 was jailbroken.
    :p
     
  14. cadeucsb macrumors member

    Joined:
    Jul 5, 2007
    #14
    its definitely the power cord nonsense. Dont listen to the greenpoison installer. Simply ignore it telling you to plug in the power cord. Just plug in USB when it tells you to, then wait until it says press Menu + Play/Pause and continue on.
     
  15. mdwsta4 thread starter macrumors 65816

    Joined:
    Jul 23, 2007
    #15
    That might very well be. I'm using one from a bluetooth charger. That's the only USB->micro USB cable I have.

     
  16. tom1971 macrumors 6502a

    Joined:
    May 15, 2007
    #16
  17. harpster macrumors regular

    Joined:
    Jan 26, 2010
    #17
    There are some good tips here:
    http://forums.plexapp.com/index.php/topic/23394-greenpois0n-rc6-guide

    A couple of points that may have already been mentioned...

    1. Use the correct cable Micro USB TYpe B Data Cable. The cable I used came from a Blackberry phone and it worked.

    2. Greenpois0n tells you to plug in the usb After pressing the Jailbreak button. Many people say to plug in the USB cable Before pressing Jailbreak and that's what worked for me.

    3. Don't release the buttons too late - if you see the count down at 1 you might have missed that tight window for that step. To go into the DFU mode press the Menu & Play/Pause immediately (as soon as it tells you to) and release the buttons before the countdown of 1. The timing seems to be important so don't release the buttons too late.

    4. When done go and do something. Do not disconnect the USB cable for a few minutes as it needs to do some things and reboot the ATV2.

    The GP jailbraeak seems much more finicky that the Seas0npass - took me longer to do it successfully. Plugging in the USB prior to pressing Jailbreak made a big difference for me.

    If all else fails - you may need to restore the ATV2 to factory settings which is easy to do in itunes using the USB cable. Just make sure it's the current release the matches the Jailbreak release. As of today it's running software version 4.1.1 (iOS 4.2.1). iOS4.3 is expected soon.
     

Share This Page