Why can't I partition using BootCamp?

Discussion in 'Mac Basics and Help' started by Zach808, Mar 24, 2010.

  1. Zach808 macrumors newbie

    Joined:
    Mar 21, 2010
    #1
    I've tried, and it says it can't move files and to format it as a Mac OS Extended (Journaled) disk, which it already is. Exactly what files can't it move?

    I've tried repairing permissions and removing a ton of large files, and still same problem. It's unlikely that I'll be able to get an external hard drive any time soon, so Idefrag and reformatting are out of the question. Any ideas?
     
  2. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #2
    I used a TechTool bootable dvd to defrag mine. It worked. I think other disc tool dvds can do this too. Just make sure you use a version that supports your OS version or bad things can happen.
     
  3. MacDawg macrumors P6

    MacDawg

    Joined:
    Mar 20, 2004
    Location:
    "Between the Hedges"
    #3
    You don't have enough free contiguous space
    Defrag may or may not help, because the issue is not just fragmentation but contiguous space

    Really your best (only?) option is cloning, erasing the disk, restoring the clone and running Bootcamp Assistant again
     

Share This Page