Why can't I see my movies on my iPhone 4s

jooserparfs

macrumors newbie
Original poster
Dec 8, 2011
9
0
I've just got a new iphone 4s and I need to put some of my own videos on the phone. I've converted a test video into mp4 m4v with h.264 compressing. Then I put them into Itunes and transferred them using sync. Itunes says that they are now on my iphone, however, when I try to find them on my iphone, I can't see anything in my videos app. Where are they???
 

jooserparfs

macrumors newbie
Original poster
Dec 8, 2011
9
0
OK no one wants to answer me yet. Maybe I need a nicer message. How about if I add...

So I made a couple of videos today about hockey, They were shot on a Canon 5d. I encoded them with mpeg streamclip to mp4 with h264 compressor. I also tried the ImTOO iPhone Video Converter trial version just to make sure it wasn't my encoding as the problem.

OK, now I have my iphone plugged in and visible in itunes. I drag the new videos into my movies on itune. Then I press sync under my iphone tab. They transfer. They are visible in the movies tab under my iphone. They play in the itunes player.

But.... they are still no where to be found on my iphone. My videos app still says no music, you can download music from itunes. Why does it say "no music". Shouldn't it be saying "no videos". Maybe this is my problem.

On my iphone, I go to settings / video:

Start playing - "Where I left off"
Closed Captioning - "off"

Home Sharing
Apple ID - empty
password - empty

"An Apple ID is required to use Home Sharing."

OK so is THIS me problem??? Home sharing??? I enter my apple ID. Password.

re-sync... nothing. No videos in my video. WTF!!!

please help
 

jooserparfs

macrumors newbie
Original poster
Dec 8, 2011
9
0
Bill thank you for your advice but it didn't work. When I look in my videos, I still can't see anything but a big music note and the words "No Music". Wierd!!!
 

teamjaycub

macrumors 6502
Oct 22, 2011
291
12
Bill thank you for your advice but it didn't work. When I look in my videos, I still can't see anything but a big music note and the words "No Music". Wierd!!!
You have to open the video app, not music app. The iPod app got separated in iOS 5.
 

Clix Pix

macrumors demi-goddess
Make sure in the tabs section when your iPhone is set up for synching that the video tab is set for "all movies" or selected movies, whatever you want to do. it's not automatic, you have to make sure that the designation is check marked however you want to do things.
 

jooserparfs

macrumors newbie
Original poster
Dec 8, 2011
9
0
Well I think I am using the video app, because I am syncing all my videos through "movies" and then I am looking in my "videos" app on my iphone. But the "videos" section is saying "no music" for some reason.

OK, thank you in advance, but can you be a little more specific where I should be switching my tabs. Do I do it in Itunes or do I do it somewhere on the iphone???
 

jooserparfs

macrumors newbie
Original poster
Dec 8, 2011
9
0
I am now at the point of changing a setting option because my videos are not showing up where they should be
 
Last edited by a moderator:

jooserparfs

macrumors newbie
Original poster
Dec 8, 2011
9
0
Yes here is what I've checked on my iphone:

photos app
videos app
camera app

When I hook up my iphone to my PC, there are several videos listed under my movies tab. I can play them in the itunes player. Where are these videos supposed to be viewable on my iphone? What app? Is there a setting a need to flip to get them to pop up? I know it's not a compatibility issue because I've converted these videos in several different mp4 and m4v formats and cmon this is the brand new iphone 4s.. there should be no problem playing video. I've been watching videos on my youtube app and they look great.

I appreciate all your ideas!!!
 

jooserparfs

macrumors newbie
Original poster
Dec 8, 2011
9
0
In the iphone settings, under video, there is a weird setting called home sharing... it requires my apple id and password. What is that for?

Here's a stupid question...

On my iphone, in the Videos app, if there is nothing there, why would it say "no music"... shouldn't it say, "no videos"???
 
Last edited by a moderator:

jooserparfs

macrumors newbie
Original poster
Dec 8, 2011
9
0
So this is definitely the problem. For some reason, my VIDEOS app on my iphone does not have video enabled or something like that. Or it thinks it should be playing music. There has to be a setting somewhere that I need to switch to enable video to be played in this app. I wonder if there is something I can do to reset this, or uninstall and re-install.

Thank you for your response, this is leading me in the right direction!

OK, so I wasn't crazy. I knew this was something weird. And you probably won't believe me but I found the answer in another forum and it goes like this:

Hey guys!
This literally just happened to me and I solved it in 1 minute!

What you have to do is...

Settings > general > International > Language > *change the current language to a different (I chose British English to English) and then allow the language to change* > once you're back at the home screen click on iPod and allow the library to load :]

Hope this helps! it was an iPhone 4 on 4.1 :]
Toshiba Laptop, Windows Vista, iPhone 4, iPhone 3g, iPod touch 1st gen, iPod touch 2nd Gen

Thank you Nickw73 from https://discussions.apple.com/thread/2521992?start=15&tstart=0[/url]

check it out... it's no joke. All you have to do is change the language settings
 
Last edited by a moderator:

ObuckiO

macrumors regular
Dec 9, 2011
223
1
Ohio
iphone reply & question for video transfer

I've just got a new iphone 4s and I need to put some of my own videos on the phone. I've converted a test video into mp4 m4v with h.264 compressing. Then I put them into Itunes and transferred them using sync. Itunes says that they are now on my iphone, however, when I try to find them on my iphone, I can't see anything in my videos app. Where are they???
I'm kinda asking for the same help. I have been able to save imovie projects on iphone, but they always go to "Recently Added" only. I cannot figure out how to move them to videos, (once to podcast by mistake) After so long they are gone from recently added to who knows where?? In itunes (on MacBook), my videos are all ghosted, and my movies are all lit up. I don't want no 2hr. movie on iphone though. The iphone itune's menu is not the same as the itunes on MacBook lingo "so to speak" I have made iphone versions of all my projects and they still are ghosted/not easy to transfer. :confused:
 

ObuckiO

macrumors regular
Dec 9, 2011
223
1
Ohio
imovie11 tranfer problem

I am pretty good with imove11, as in making the video. I cannot seem to downpack the differant versions of transfer though. As in an earlier post, I'm having trouble with putting project on iphone in places to save, (always "recently added" that erases soon)...I made a video for someone that will not play on their computer (windows 7 + not that nice a computer), The imovie project plays like they're strobe lights in it..(graffix card sucks?) Ok, I burned a DVD for her and same thing. It don't play in her DVD home player either. I am able to play it on "my" Playstation3, iphone and MacBook. IDVD is what i tried to burn through today, but not tested yet. I'm new to this forum and just saying HI to everyone... If any one needs some help with imovie tricks,tips,etc. Feel free to ask me. I might be able to help. Thanks.:apple:
 

friedchic

macrumors newbie
Sep 8, 2015
1
0
So this is definitely the problem. For some reason, my VIDEOS app on my iphone does not have video enabled or something like that. Or it thinks it should be playing music. There has to be a setting somewhere that I need to switch to enable video to be played in this app. I wonder if there is something I can do to reset this, or uninstall and re-install.

Thank you for your response, this is leading me in the right direction!

OK, so I wasn't crazy. I knew this was something weird. And you probably won't believe me but I found the answer in another forum and it goes like this:

Hey guys!
This literally just happened to me and I solved it in 1 minute!

What you have to do is...

Settings > general > International > Language > *change the current language to a different (I chose British English to English) and then allow the language to change* > once you're back at the home screen click on iPod and allow the library to load :]

Hope this helps! it was an iPhone 4 on 4.1 :]
Toshiba Laptop, Windows Vista, iPhone 4, iPhone 3g, iPod touch 1st gen, iPod touch 2nd Gen

Thank you Nickw73 from https://discussions.apple.com/thread/2521992?start=15&tstart=0[/URL]

check it out... it's no joke. All you have to do is change the language settings
This is crazy but it helps!
Thank you!
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.