Why can't I send text messages by choice always? Frustrating.

Discussion in 'iOS 8' started by fdg46, Oct 12, 2014.

  1. fdg46 macrumors newbie

    Joined:
    Sep 10, 2014
    #1
    So here is the situation. My girlfriend has both an iPhone and iPad. Her iPad was at home on wifi. Her data plan got close to going over so she had to turn off her data, making it unable to receive iMessages on her iPhone while she was out.

    When I try to message her, it defaults to iMessage as usual but since her iPad is at home and connected, they deliver immediately. This made it impossible to revert them to text messages and message her, sans turning off my own data, which seems a hassle.

    Why don't I have the option to send text messages always? It only allows it on iMessages they have not been delivered and I'm not sure why it has to be that way.

    I understand thus is a niche situation but it was incredibly frustrating. I couldn't message her at all without turning off my own data/iMessages, since she has an iPad connected as well.
     
  2. gordon1234 macrumors 6502a

    Joined:
    Jun 23, 2010
    #2
    You could turn off iMessages entirely on your device, but it sounds like you don't want to do that.

    It sounds like the best solution would be for your girlfriend to turn off iMessage on her phone if she's not going to have data enabled all the time. This would ensure that any messages sent to her phone number will go as SMS, regardless of the sender's settings. As long as her phone number is registered as being able to receive iMessage, anyone with an iDevice that tries to message her won't be able to reach her on her phone. You may know to try and force them to send as SMS, but chances are no one else will.
     
  3. afsnyder macrumors 65816

    Joined:
    Jan 7, 2014
    #3
    Hold down on the message as if your gonna copy it and click "Send as text message."

    There, problem solved. It should default to text message for some time but if not just repeat the same process above ^
     
  4. coolio93 macrumors 6502

    Joined:
    Apr 15, 2013
    Location:
    Houston, TX
    #4
    This option isnt there if the message gets delivered immediately.

    To OP: You could turn off your data on your phone as well and then text your gf. That'll force the messages to go as text messages.
     
  5. afsnyder macrumors 65816

    Joined:
    Jan 7, 2014
    #5
    The message should only get delivered if she has wifi or data on... since she doesn't, he should have the option.
     
  6. coolio93 macrumors 6502

    Joined:
    Apr 15, 2013
    Location:
    Houston, TX
    #6
    Its getting to delivered to her iPad which is at home connected to wifi. Thats why the OP is having the issue.
     
  7. afsnyder macrumors 65816

    Joined:
    Jan 7, 2014
    #7
    Interesting situation. On Yosemite, you have to manually select Text Messages vs iMessage and simple toggle switch would be nice.. maybe under details?
     
  8. Purex, Oct 12, 2014
    Last edited: Oct 12, 2014

    Purex macrumors member

    Joined:
    Aug 22, 2013
    #8
    Why can't I send text messages by choice always? Frustrating.

    In the iPad ( imessage-send and receive settings ), change the iMessage Contact to the Apple ID email . This way, the "text" wont be delievered in her iPad, being forced to go through SMS to the iPhone.
    She still can be reached by iMessage in the iPad if you send a "text" to her e-mail / Apple ID.
     
  9. mKTank macrumors 68000

    mKTank

    Joined:
    Jul 2, 2010
    #9
    Re-read the OP.
     
  10. Apple blogger macrumors 6502a

    Joined:
    Feb 28, 2013
    #10
    I think tHat happens only before she replies Or is seen by her right?
     
  11. Mr Hands macrumors regular

    Joined:
    Oct 11, 2014
    #11
    Have her-

    1. Not use so much data.
    2. Get a bigger data plan.
    3. Get unlimited data.

    Just suggestions. :)


    Man I'm glad I've had unlimited for all these years, there are so many little situations like this that I've never once had to worry about.
     
  12. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #12
    Actually only before it gets delivered (whether or not its even seen or replied to).

    ----------

    Yeah, sounds like either one of those options are the best available workarounds so far.

    ----------

    Something like that would be really good to have. At least to be able to set it on a per conversation level (kind of like the new per conversation DND) and/or per message level where you can select one or the other.
     
  13. benrd macrumors member

    Joined:
    Jan 11, 2008
    #13
    can she not just turn iMessages off on the iPad?
     
  14. macduke Suspended

    macduke

    Joined:
    Jun 27, 2007
    Location:
    Central U.S.
    #14
    I ran into this problem with my uncle recently. He recently had his iPhone sim in whatever that latest Windows Phone is that has Cortana because he found it really cheap online. I couldn't send any messages to him when he was out and about because they were being delivered as iMessages to his iPad at home. We ended up using WhatsApp, but that requires data. I agree that there should be a setting or something, but this isn't a common scenario. Most people don't turn off data on their iPhone—because what's the point of having an iPhone if it doesn't have data?
     
  15. Apple blogger macrumors 6502a

    Joined:
    Feb 28, 2013
    #15


    I did try it out though.. It turn out if it's delivered and not seen you can still resend it as text ...but then I don't know if the other guy will receive both imessege or text or not.. Can you also try and see what happens with you?
     
  16. KUguardgrl13 macrumors 68020

    KUguardgrl13

    Joined:
    May 16, 2013
    Location:
    Kansas, USA
    #16
    So I tried testing it out with my iPhone and iPad and my boyfriend's iPhone. I could not figure out a way for his phone to send only SMS messages to my iPhone even when I had iMessages disabled on the iPad and cellular data and iMessages off on my phone. I could send SMS to him, but it defaulted back to iMessage when his phone tried to reply. I could press and hold on the iMessage to select send as text which went through. We're both on iOS 8.0.2. It's weird because I remember back during iOS 6 I could turn off iMessage and only receive SMS messages. Wonder if it's an iOS 8 bug because I never did it with iOS 7.

    But I'm done testing because I accidentally deleted our message thread on boyfriend's phone and he'll be annoyed when he learns he has to restore his phone from his backup to get them back. Oops...
     

Share This Page