Why can't I upgrade to El Capitan?

Discussion in 'OS X El Capitan (10.11)' started by Miqs, Jan 28, 2016.

Tags:
  1. Miqs macrumors member

    Miqs

    Joined:
    Mar 22, 2013
    Location:
    Bedfordshire, UK
    #1
    I am told my version of Safari (v6.1.6) is out of date and needs to be updated to make more secure. Following the links I see in the app store I have one upgrade to download. However when I attempt to download it says I cannot install it on my iMac, but I read it can be used on all OS after 10.6. I am running 10.7.5 on a 8 year old iMac with increased memory. So why can't I install it? If my iMac is too old why does it recommend it?
    Thanks.
     
  2. keysofanxiety macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #2
    It just automatically recommends it, but on some computers you can't upgrade. It's always been that way unfortunately. Best thing to do is right-click the upgrade banner in the App Store and click 'Hide', so it won't bother you in future.

    The 2007 MacBooks can also support up to Lion, but won't go beyond that.

    If memory serves, I think the earliest iMac that can run El Cap is the 2007 model.
     
  3. Miqs thread starter macrumors member

    Miqs

    Joined:
    Mar 22, 2013
    Location:
    Bedfordshire, UK
    #3
    As I suspected. Thanks.
     

Share This Page