Why can't Mac Pro 1.1s use newer video cards?

Discussion in 'Mac Pro' started by ADDvanced, Nov 9, 2015.

  1. ADDvanced macrumors newbie

    ADDvanced

    Joined:
    Nov 8, 2015
    #1
    I'm looking to upgrade my machine's GPU, but many video cards say only 3.1, 4.1 or 5.1 mac pros or later. What is preventing my machine from using these cards?

    I have already installed El Capitan and modded the EFI, it works great. Thanks!
     
  2. cw48494 macrumors regular

    cw48494

    Joined:
    Jun 17, 2015
    #2
    If you're running the Tiamo or Pike R. Alpha boot.efi that allows these machines to run 10.8 or later, you're fine using any of those cards.
     
  3. SDAVE macrumors 68040

    SDAVE

    Joined:
    Jun 16, 2007
    Location:
    Nowhere
    #3
    It's also PCIe 1.1 I think, which is really old. Almost 10 years.
     
  4. Fl0r!an macrumors 6502a

    Joined:
    Aug 14, 2007
    #4
    Your MacPro can't take use of flashed EFI64 cards (e.g. any Nvidia card from the last years), so you won't see a boot screen with those. This will not change when you modify your boot.efi, 2 completely different things!

    Besides that the supported GPUs are only determinded by the installed OS, so of you run Yosemite or El Capitan you can use the same cards as a newer MP running the same OS.

    The most recent flashable cards are Radeon HD 7xxx/R9 cards (check other threads). Obviously they'll be bottlenecked in games by your 10yo hardware.
     
  5. ActionableMango macrumors 604

    ActionableMango

    Joined:
    Sep 21, 2010
    #5
    It will work after booting. The reason why people said it won't meet your needs in your other thread is because in the other thread you said you needed boot screens, which you aren't mentioning in this thread.
     
  6. SDAVE macrumors 68040

    SDAVE

    Joined:
    Jun 16, 2007
    Location:
    Nowhere
    #6
    Slap in a used GT120 if u need bootscreen, OP.
     

Share This Page