Why can't you swipe notifications in the top right off the screen anymore?

johnnnw

macrumors 65816
Original poster
Feb 7, 2013
1,210
9
It's pretty annoying. Those little rectangles that appear on the right side for system notifications and now websites too.

How do you make them go away, besides waiting or clicking it (which causes that app to open).

You used to be able to swipe right on the trackpad over them to make it go away. No longer works.
 

Gav2k

macrumors G3
Jul 24, 2009
9,218
1,584
Honestly it bugs me too so I changed the time it sits there to 1 second.

Open terminal and type

defaults write com.apple.notificationcenterui bannerTime 1

Change the 1 if you want longer.

Log off then on and it'll be changed.
 

johnnnw

macrumors 65816
Original poster
Feb 7, 2013
1,210
9
Honestly it bugs me too so I changed the time it sits there to 1 second.

Open terminal and type

defaults write com.apple.notificationcenterui bannerTime 1

Change the 1 if you want longer.

Log off then on and it'll be changed.
Thank you.

It seems so silly there is no way to close them at your will. Doesn't make sense to me.

While not a perfect solution this is better than nothing :)
 

airlied

macrumors 6502
Jul 8, 2011
381
56
I don't know what are you guys talking about here. I can move the banner away by swiping the trackpad or magic mouse with cursor on it. Its easy as always guys, never bothered me.

Some banners cannot be moved that way because they have special functions (like messages banner you can do a quick reply without launching the app so you have to make it disappear manually).
 

matrix07

macrumors 601
Jun 24, 2010
4,943
1,458
Some banners cannot be moved that way because they have special functions (like messages banner you can do a quick reply without launching the app so you have to make it disappear manually).
Hmm.. I can swipe away iMessage notification just fine in Mavericks.
 

johnnnw

macrumors 65816
Original poster
Feb 7, 2013
1,210
9
I can swipe banners away just fine with Magic Mouse...

Clean install of DP 6......
That's weird. I used to always do it but now it's not working.

I'm on the Public beta though, so maybe it's different.
 

Watabou

macrumors 68040
Feb 10, 2008
3,414
691
United States
Also works fine for me with the built in trackpad, I don't think it ever stopped working for me, even in previous DPs

If it's not working for you then that probably means it's a bug.
 

phobox

macrumors member
Dec 25, 2007
78
0
Its definitely working here too on DP6, I can swipe away with my magic mouse. Also worked on DP5.
 

johnnnw

macrumors 65816
Original poster
Feb 7, 2013
1,210
9
Turn on Do Not Disturb?
I like the notifications. Just don't like not being able to get rid of them when I need to click something behind it. It used to be easy.

For sake of my sanity:

Is anyone able to swipe banners off the screen on Yosemite public beta 1?

----------

Also works fine for me with the built in trackpad, I don't think it ever stopped working for me, even in previous DPs

If it's not working for you then that probably means it's a bug.
Sent to Apple through feedback assistant assuming you're right.
 

piller97

macrumors newbie
Aug 15, 2014
26
2
I can still swipe to dismiss just as in mavericks....
Currently running DP5, perhaps its different in DP6


Is anyone able to swipe banners off the screen on Yosemite public beta 1?
Note: When i was running PB1 i was able to dismiss with swipe as well........
 

Kasalic

macrumors regular
Jan 20, 2011
159
0
I like the notifications. Just don't like not being able to get rid of them when I need to click something behind it. It used to be easy.

For sake of my sanity:

Is anyone able to swipe banners off the screen on Yosemite public beta 1?

----------



Sent to Apple through feedback assistant assuming you're right.
I can confirm that I can swipe away notifications in Yosemite PB1 :)
 

johnnnw

macrumors 65816
Original poster
Feb 7, 2013
1,210
9
Damn... that's annoying that's not working for me.

Is there possibly a setting for this that I have turned off?

Thought maybe BTT was interfering, Quit that app and tried again, still not working.
 
Last edited:

ProphetX

macrumors 6502
Feb 8, 2011
354
102
Maybe you doing it wrong. I never knew that you could even swipe notifications away and its working for me perfectly.
 

johnnnw

macrumors 65816
Original poster
Feb 7, 2013
1,210
9
Maybe you doing it wrong. I never knew that you could even swipe notifications away and its working for me perfectly.
I've been doing it fine since notifications were a thing, it used to work fine. So I'm not doing it wrong.
 

e1ven

macrumors newbie
Aug 25, 2014
1
0
Ensure it's enabled

For whatever it's worth, you should double-check that "Swipe between pages" is enabled, under Trackpad preferences | More Gestures, in System Preferences.

I've been using Safari more in Yosemite, but I found the Swipe feature annoying, so I disabled it.
But this "Swipe between pages" option also disables the ability to dismiss notifications by swiping.

Just thought I'd suggest it, in case you ran into the same problem.
-CPD
 

johnnnw

macrumors 65816
Original poster
Feb 7, 2013
1,210
9
For whatever it's worth, you should double-check that "Swipe between pages" is enabled, under Trackpad preferences | More Gestures, in System Preferences.

I've been using Safari more in Yosemite, but I found the Swipe feature annoying, so I disabled it.
But this "Swipe between pages" option also disables the ability to dismiss notifications by swiping.

Just thought I'd suggest it, in case you ran into the same problem.
-CPD
You might be a genius. It was disabled. I used to use that command for BetterTouch to do something else. I reenabled it and the next notification I get I will report back.