Why do I have to enter password to move files & folders??

Discussion in 'macOS' started by glossywhite, Aug 14, 2009.

  1. glossywhite macrumors 65816

    glossywhite

    Joined:
    Feb 28, 2008
    #1
    Hi all. Just did "Archive & Install" and when I am trying to move my OLD documents to the NEW locations, I get a PASSWORD dialog box, and it will only move/copy/trash them once I enter my password.

    I have tried resetting "Everyone:No Access" and "<myusername>:read&write" from CMD+I for all relevant files and folders, but it still does this :confused:

    This is pertinant to stuff such as ~/Documents ~/Pictures etc, (NOT ~/Library by the way). Thanks
     
  2. dec0de macrumors newbie

    dec0de

    Joined:
    Dec 29, 2007
    Location:
    Nashville, TN
    #2
    The same thing happened to me a few months back. In the Disk Utility run Repair Permissions and that should take care of all of your issues. At least it did for me.
     
  3. foeniox macrumors newbie

    foeniox

    Joined:
    Dec 24, 2007
    #3
    All of your old files were created by your old user, you now have a new user.

    Even if the names are the same they're different users. Lots of people have the same name but they're different people.

    You dont have permission to move this other users files (the old user) so osx goes into a higher permissions level to move them, hence the password.


    by repairing disk permissions you change the permissions on the files to that of your new user and hence you may do as you please with them.
     
  4. PhilthyM macrumors newbie

    Joined:
    Nov 29, 2007
    Location:
    Melbourne
    #4
    That may be the answer to some issues, but there are other problems that don't appear to fit that answer.

    I am in the habit of copying DVD content back to the HDD after burning. When I subsequently delete the VIDEO_TS directory I have to enter the password. I have tried repairing permissions before attempting to delete and am still prompted for a password. That seems to suggest something other than permissions?
     
  5. foeniox macrumors newbie

    foeniox

    Joined:
    Dec 24, 2007
    #5
    I see what you're saying here but if you're asked for a password to perform a file operation - its permission related. The OS is saying your current permissions just don't cut it, but an admins (of course) will - hence the admin password request in order to use the admin permission state.

    The behaviour you describe could be the result of many things. Disk utility won't change the permissions of every file across the hard disk, it modifies only those it considers to have incorrect permissions. Running permission repair doesn't allow me to subsequently modify other users files!

    So, for whatever the reason may be, the os believes the permissions on the video_ts folder are correct and will not alter them.
     

Share This Page